Supra Forums banner
1 - 3 of 3 Posts

·
Flying Dutchman Pilot!
Joined
·
2,173 Posts
Discussion Starter · #1 ·
I have been having problems with my FJO wideband reading inaccurately on my car. I figured there would be more experienced people with this kind of problem in the MKIV section. At WOT the car is pinned rich, even when I have leaned the car to the point of it breaking up. Cruising, part throttle and idle seem perfect. The sensor is mounted about 3 inches back from the turbo right next to the stock sensor. I called the other day and the tech at FJO told me it could be a leaky turbo seal. I do not believe this to be the case. I had an engine in the car at one point that blew plumes of smoke from a bad ring and the wideband worked fine then. The wideband did seem to work properly at one point, it seems a few months ago this started. I tried a brand new sensor and it reacted identically. What can I do to resolve this issue and do you think its possible the controller is faulty or something is going on with the car to cause this? Has anyone else had a similiar issue? If so what solved it if you did?

Thanks

Dave
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top