Supra Forums banner

1 - 3 of 3 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Today I installed a Fluidyne radiator in my '97 (at the same time as the install of my Buscher IC...geeze, what a job...). Anyway. I had heard this was a drop-in replacement, in my case it didn't turn out that way. I had some clearance issues with the fan shroud, the fluidyne was about 1/8" or so too wide to get the shroud to fit (chiseling off the "Fluidyne" badge on the side helped), the shroud bolts didn't quite line up, etc. After some trimming, I got a decent fit for the shroud, then I go to reinstall the (stock) airbox air scoop...Surprise! no attachment point for the bolt! It didn't even occur to me to check for this before I installed it, this is a bummer as I intend to run the stock air box for awhile. Has anyone come up with a fix for this, short of pulling the rad and having something welded on?

thanks,

Bob
 

·
Administrator
Joined
·
17,223 Posts
Bob,

My new Supra is Fluidyne radiator and dual electric fan equipped. I could snoop around a bit to find you some answers, but the installation work was completed on this one well before I bought it. I don't have the stock airbox anymore on mine though, so I may not be able to help you much.
 
E

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Bob said:
Today I installed a Fluidyne radiator in my '97 (at the same time as the install of my Buscher IC...geeze, what a job...). Anyway. I had heard this was a drop-in replacement, in my case it didn't turn out that way. I had some clearance issues with the fan shroud, the fluidyne was about 1/8" or so too wide to get the shroud to fit (chiseling off the "Fluidyne" badge on the side helped), the shroud bolts didn't quite line up, etc. After some trimming, I got a decent fit for the shroud, then I go to reinstall the (stock) airbox air scoop...Surprise! no attachment point for the bolt! It didn't even occur to me to check for this before I installed it, this is a bummer as I intend to run the stock air box for awhile. Has anyone come up with a fix for this, short of pulling the rad and having something welded on?

thanks,

Bob
I think it was a pretty straight forward install for my 98tt. I didn't have to trim the fan shroud to get it to fit..... Oh, did you remember to use the teflon thread tape to wrap the coolant sensor and drain bolts when installing? I didn't use it the first time and it LEAK from the bottom and it looked like the car is bleeding!:eek: :eek: I had to take everything off and redo it the second time....fixed it.....whew!!:mad:

regards,,,



------------
eddie c.
98tt
 
1 - 3 of 3 Posts
Top