Supra Forums banner

1 - 17 of 17 Posts

·
Banned
Joined
·
1,533 Posts
Discussion Starter #1
background info here:
http://www.supraforums.com/forum/showthread.php?s=&threadid=260698&highlight=journal
And here:
http://www.supraforums.com/forum/showthread.php?s=&threadid=239861&highlight=journal


Anyways after 3 months the car is now at Broadway Preformance, I was going to take it to RTC, but they've always busy, and John got some good reviews from some of my old DSM associates.

John, pulled the codes and got an error for the coolent temp sensor (or thermostat sensor)
part is now on order

He pulled back the afc,
and will be redoing the fmic piping so it doesn't hang an inch off the floor.

keeping my fingers crossed:rolleyes: , hopefully the car will be ready by Wed
(he's pretty busy now due to the DSM shoot out coming up)
 

·
Newbie
Joined
·
11,219 Posts
aliga said:
I remember back when I was talking to the kid that worked on the car. He was blaming that the pipings are all miscut and shit, and that he had to ghetto put it together or something. Anyways in the end, you get what you paid for.

Looks like you made a better step in taking it to a shop, not someone's back yard.
 

·
Registered
Joined
·
564 Posts
wow you are having the exact same problem that I am. My car is running insanely rich right after doing NA-T, too rich to drive, and my car has been at the shop for months. I am running a different setup though, but still the same problem. I am running vpc/afc, but still getting the exact same problem. I have a wideband attached and im at around low 10s...if you find anything out please let me know, as I bet my problem is the same one you are having.
 

·
Registered
Joined
·
1,705 Posts
jargon you know what your problem was. it helps when they install the damn air intake sensor. no mystery there. hope u both get up and running soon. btw got my gold plated NAT emblem worked out.
 

·
Registered
Joined
·
564 Posts
yes we installed a 2200 ohm resistor. And the air temp sensor didnt fix the problem. lol still runs the same....so we have no idea what it is. Angel came by and he's stumped too...we also double checked all the wiring.
 

·
Registered
Joined
·
1,705 Posts
daren is only 95.00 per hour, sounds cheap for the peace of mind he delivers.
 

·
Banned
Joined
·
1,533 Posts
Discussion Starter #12
Sorry, no drill tap yet,
I haven't been tot he car, I just had Broadway's tow guy pick up the car.

I'll see if I can get a ride out there next week.

Been asking Jason to drop off the rest of my stuff at the shop, but he hasn't yet



aliga said:
wtf?

anyway, goodluck man.

did you find the drill/tap?

thanks.
 

·
Registered
Joined
·
495 Posts
Let us know how your experience with Broadway is....looking for a shop to do some work.

Either:
1. RTC
2. Broadway Performance
3. XtremeMotorWerks



kmn5 said:
Sorry, no drill tap yet,
I haven't been tot he car, I just had Broadway's tow guy pick up the car.

I'll see if I can get a ride out there next week.

Been asking Jason to drop off the rest of my stuff at the shop, but he hasn't yet
 

·
Banned
Joined
·
1,533 Posts
Discussion Starter #14
do a search on the northeast forums
there's info there on RTC and XtremeMotorWerks


TurboXpress said:
Let us know how your experience with Broadway is....looking for a shop to do some work.

Either:
1. RTC
2. Broadway Performance
3. XtremeMotorWerks
 

·
Registered
Joined
·
240 Posts
TurboXpress said:
Let us know how your experience with Broadway is....looking for a shop to do some work.

Either:
1. RTC
2. Broadway Performance
3. XtremeMotorWerks

Go with #1 :).....They're there for a reason :)..Even subliminally(sp?) they're #1


kmn5...Sorry that they were too busy for ya.....They had a few cars that were being completed when you were calling from what I understand....I know there's a new batch of cars in...I know they hate to not be able to help but they're full for a reason.....Good Luck with Broadway John(i think that's his name i'm bad with names) is a nice guy......



Dan
 

·
Registered
Joined
·
495 Posts
dt1313 said:
Go with #1 :).....They're there for a reason :)..Even subliminally(sp?) they're #1


kmn5...Sorry that they were too busy for ya.....They had a few cars that were being completed when you were calling from what I understand....I know there's a new batch of cars in...I know they hate to not be able to help but they're full for a reason.....Good Luck with Broadway John(i think that's his name i'm bad with names) is a nice guy......



Dan

Dan,

I pm'd you a while back about RTC. I was going to take my car there, but found someone locally to do a leakdown and compression test. The motor is good :). Still need to diagnose the problem. If I ever need any future work done, RTC will be the first ppl I contact. Thanks!
 

·
Banned
Joined
·
1,533 Posts
Discussion Starter #17 (Edited)
hey guys, positive update
I finally got my car back today
Got a ride from my friend to Broadway Performance.
John is a GREAT guy, redid everything.
Car starts and idles as good as if not better then
before any of the mods were started. Shifter doesn't
vibrate at all because of the smoother idle.
He even adjusted the fmic piping so it doesn't hang
off the floor by an inch (literally!)

Everything was checked and the system was pressure
tested to 20psi.

John did a great job on the car! :bigthumb:

here's a pic
I still need to reroute my bov into the intake


as for Xutech (Jason): well after looking through the
car I'm missing a bunch of stuff still
Gazi's Tap and Die (Gazi: I'll pay you for them at the next event)
my 525 cc injectors, my HID foglamp, egt sensor and
some misc crap
 
1 - 17 of 17 Posts
Top