Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #1 ·
Does anyone have a suggestion for a good fuel Pressure Regulator with gauge for a 95 NA-T Supra with 525cc injectors on stock fuel pump,Lexus AFM and SAFC with both hi and lo throttle tuned. I have plenty of fuel at this point so I know the pump is working fine.

I seem to get a surge in pressure when the peddle is first pressed hard( 75% or more throttle the car goes massively rich for 100rpms or so) I think this is due to my stock regulator wearing out (110,000 miles).

Links would be appreciated.
Or suggestions if poeple think the regualtor isn't the case.

Thanks
Matt
 

·
feeding your habit
Joined
·
4,015 Posts
Check your vacuum line to it and make sure it comes right off the mani and not anything teed to your vaccuum tank.
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #4 ·
Aeromotive
Thanks I'll look into one of those.

Check your vacuum line to it and make sure it comes right off the mani and not anything teed to your vaccuum tank.
Nothing teed into this line but I think I have one of those weak silicone lines on, so maybe that is the issue. Thanks for the possible fix there.
 

·
Edge On The GE-T Epidemic
Joined
·
575 Posts
Sounds to me like a tuning related issue with the nat. The richspot is hard to eliminate without standalone. I had something similar on safc and vpc. Try the aeromotive 1000 and attempt to drop it. It may not help much tho
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #6 ·
Man I was afraid that may be the case. Well I'm going to try a new FPR, switch to VPC, and see if that helps at all. If it doesn't then I guess I'll be saving for an AEM. Other then the rich spot the car is running near perfectly. But in AutoX I seem to bog due to the rich spot and the RPM range whille coming out of turns, so i need to figure something out.
 
1 - 6 of 6 Posts
Top