Supra Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
ok so i still have a fuel gauge issue...but now i have more info...

the background: when i fill up the car full (and i know its full) the gauge only goes to a little over a quarter. and then goes down as i use gas so at about 3/4 of a tank its empty.

the new info: i ran it down really low and found out that the low fuel light still comes on.

would this mean that its the gauge thats having the problem and not the sending unit? thats what i am thinking anway.

would changing the gauge help?
 

·
I'll nevAr go single!
Joined
·
994 Posts
Hah, hey man didnt know you where on here.
Here's some old post's of mine refering to the gauge issue with that car, maybe you'll find something that helps.

As you can see, I chased that problem for awhile.

http://www.supraforums.com/forum/showthread.php?t=309619
http://www.supraforums.com/forum/showthread.php?t=301860
http://www.supraforums.com/forum/showthread.php?t=297364
http://www.supraforums.com/forum/showthread.php?t=276028

Looking at these old threads also reminds me, ran outa gas onetime and didnt know it, went chasing every problem I could think of, and replaced the Fuel Filter, so, you got a fairly new Fuel Filter on the car also :bigthumb:
 

·
Registered
Joined
·
1,877 Posts
10 to 1 it's your sending unit. New ones are relatively cheap. You can test the old one by removing it from your tank, plugging the connector in, and moving it by hand to see if your gauge reads correctly. Don't forget to turn your ignition on.
I had the same problem and this cleaned it right up.
 
G

·
backlighting on my dash was out so i put on the least ricey indiglos i could find. when i put them on i bumped the fuel level needleafter that it would never go all the way to full but would go way below empty. i pulled the dash back out, gave the needle a nudge upwards past full til i felt a little resistance, then went about an eigth inch more. its accurate now.
 
1 - 4 of 4 Posts
Top