Supra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
318 Posts
Discussion Starter #1
I have a couple question regarding fuel supply. I have a new motor with almost 1k miles on it and I want to make sure the fuel system is all set before I start to beat on it :)

Anyway, I have an Aeromotive pump that I power with 10 gauge wire from the battery and a Bosch relay that is triggered by the stock fuel pump wire.

My questions are as follows:

1) I noticed that the pump does not start to run until the key is turned to start. Every other car I've worked on has the pump start when the key is turned to on.

2) I noticed today while under the hood, that when I rev the motor from idle, the fuel pressure rises. Is this normal? I know FP is supposed to rise with boost, but I don't remember seeing it rise from blipping the throttle.

3) I notice from inside the car, that when I give it a little throttle, I can hear the relay for the fuel pump kick off and on.

Do I have this thing wired correctly? I'm thinking maybe I need to do the 12V bypass thing to the stock FP wire that is triggering the relay.

Any thoughts are greatly appreciated!
 

·
when this baby hits 88mph
Joined
·
2,198 Posts
Faded87T said:
I have a couple question regarding fuel supply. I have a new motor with almost 1k miles on it and I want to make sure the fuel system is all set before I start to beat on it :)

Anyway, I have an Aeromotive pump that I power with 10 gauge wire from the battery and a Bosch relay that is triggered by the stock fuel pump wire.

My questions are as follows:

1) I noticed that the pump does not start to run until the key is turned to start. Every other car I've worked on has the pump start when the key is turned to on.

mine comes on when i turn the key to on.

2) I noticed today while under the hood, that when I rev the motor from idle, the fuel pressure rises. Is this normal? I know FP is supposed to rise with boost, but I don't remember seeing it rise from blipping the throttle.

yes thats normal.

3) I notice from inside the car, that when I give it a little throttle, I can hear the relay for the fuel pump kick off and on.

whoa thats not good!

Do I have this thing wired correctly? I'm thinking maybe I need to do the 12V bypass thing to the stock FP wire that is triggering the relay.

Any thoughts are greatly appreciated!
yes id bypass the resistor and run full 12v for the relay trigger. it is probably pissed off about the 9v supply. should solve your problems.

btw- hope you can make the meet- see link in my sig for details.

good luck

dave

edit: i answered the other questions in your post but it didnt show up so well
 

·
Registered
Joined
·
318 Posts
Discussion Starter #3
Thanks Dave! I plan on doing the 12v immediately!

I am going to check my calenday at work first thing in the morning, the meet sounds excellent. You just have to promise not to laugh at my faded old jalopy! :D
 
1 - 3 of 3 Posts
Top