Supra Forums banner

1 - 7 of 7 Posts

·
411 HP GSXR / 203 HP Vrod
Joined
·
1,947 Posts
Discussion Starter #1
After pulling my dual Supra Fuel Pumps to fix a faulty connector I gently placed the pumps back in the tank. When I went to the gas station and filled the car up it only reads 1/4 tank on the gas gauge. Have I bent the float support or something? Whats the fix for this problem?
 

·
Registered
Joined
·
298 Posts
Its probably just that your float got caught on something when you reinstalled it. I had the same problem a while back. All i did to fix it was take the big screw thing off the tank, rotate it so the arrow on the top of the sending unit that holds the pumps goes in between the lines on the top of the tank. I turned the key to accessory, and it worked fine. So make sure that arrow is inbetween the lines on the top of the tank. The lines are on the lower right part of the top of the tank..
 
G

·
Guest
Joined
·
0 Posts
sorry to open up such an old thread.
i am having the fuel sender stick half way down the tank.

does anyone know where this arrow is and if it can be seen without taking off all the hoses and stuff?


i see the arrows on the tank and there is a small raised blip on the top of the metal assembly seen without unscrewing anything. is this the thing that gets line up?


thanks
 

·
95 6spd sp63'd from hell!
Joined
·
438 Posts
The top of the tank should have two lines on it to where the arrow on the "cap" lines up to. Just screw it tight and make sure that the arrow on the cap. That holds the sending unit and fuel pump assembly is lined up, with the two lines on the top of the gas tank in the trunk. And you should be good to go. I had the lil accident of bumping the fuel sending unit while taking it out or putting it in. And for alil while I had to drive by the lil yellow light next to the gauge in the dash. :rolleyes:
 
G

·
Guest
Joined
·
0 Posts
hey thanks
the only thing is that the arrow on the "cap" which tightens down is just on the outer ring and has nothing to do with the position of the actual fuel pump /sending unit assembly.
am i missing something about that?
 

·
95 6spd sp63'd from hell!
Joined
·
438 Posts
Assuming you have the fuel pump / sending unit assembly correctly situated on the "cap". It should line up correctly. If you could take some pictures? And I'll have to take some pictures with my camera phone and try to help you with this. Be patient its homecoming here tonight. =)
 
1 - 7 of 7 Posts
Top