Supra Forums banner
1 - 3 of 3 Posts

·
Search
Joined
·
3,303 Posts
Discussion Starter · #1 ·
I finally got my air/fuel gauge installed today... I've been waiting to see my AFR to post about my mileage....

I am getting ~9.5 MPG.

Fresh cleaned injectors (440)from RC eng.
New Plugs, new o2 sensor
158 psi compression on all 6 cylinders
plugs look perfect, o2 sensor looks good, even on the lean side

my afr when cruising is 14.7 +/- .3, my afr when under boost is a suprisingly steady 10.5


any ideas why i could be getting such shitty mileage? My dad's 88t got ~30 miles to the gallon... yes, that's right, 30. even with me driving it, and my driving style has not changed...

that engine had ~115,000 when we sold it, mine has 1,250 miles on it....


one other thing is that my idle insists on sitting around 1200... may be irrelevant, may not be, but i thought i'd throw it out there
 

·
Lagger
Joined
·
216 Posts
yah i am getting about the same amount of mileage as well. I did everything i could. I have a bone stock 1jz with the 330's all i have is intake and turbo back exhaust. My boost controller is set for 1bar. I have tried new plugs. Freq. oil changes. check to make sure i don't have a crimp or crack in my fuel lines. Also everything, but change the fuel filter and fuel pump.. Maybe that could be it ... Fuel filter ? As for your 1200... Thats not bad but also not good. If you can reset the i think it's called "idle set screw" down a bit. idling at 1200 doesn't sound too good..unless you have a huge set of cams.. and it won't stay on under 1200.
 
1 - 3 of 3 Posts
Top