Supra Forums banner
1 - 20 of 28 Posts

·
Moved to the dark side
Joined
·
1,147 Posts
Discussion Starter · #3 ·
before it broke it was fine but after it was all gone :)
Can't have to do much with out level. I think it's just material strengthness.. or call it weakness. a weak spot should have been there already from day 1.
 

·
Registered
Joined
·
3,647 Posts
Arnout said:
before it broke it was fine but after it was all gone :)
Can't have to do much with out level. I think it's just material strengthness.. or call it weakness. a weak spot should have been there already from day 1.
how much HP was he pushing?
what mods?
what Turbo?
 

·
25psi = 14" brakes :)
Joined
·
2,348 Posts
I'll bet too many rev's.
Nice shot of the oil squirter however. (Don't normally see them like that :) )
 

·
Mr. 2JZUL8R
Joined
·
8,901 Posts
YIKES!!!! :eek: :eek: :eek: :eek: :eek:
 

·
2/3 HP to the Paws
Joined
·
1,476 Posts
A 1jz will more or less do the same then when run with no oil in the thing.

Post some shots of the bearings, I wanna see the carnage. :D
 

·
Destroyer of Turbos
Joined
·
4,882 Posts
holy exploded metal batman!... oh the horror.... {sobs quietly in the corner} poor MK3
 

·
Your Neighborhood Pikey
Joined
·
3,480 Posts
Dude look at the condition of that motor... That thing was fragged from the start. I'm suprised it ran enough revs to do that much damage considering the shape it was in prior to the rod snapping.

- Hams.
 

·
Republican
Joined
·
9,678 Posts
JB-weld that shit, you'll be good as new!;)
 
1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top