Supra Forums banner

1 - 13 of 13 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1
So excited finally got car started! One problem though. There is no power to my EFI, fuel pump, or switching relays. I was tired and just jumped the relays to see if the beast would start. It ran and idled smoothly.

Any ideas as to why there would be no power to the relays? The car ran two years ago when the last headgasket blew! Anybody have any ideas or suggestions? I guess tomorrow after work I'll start checking everything out.
 

·
Ronin
Joined
·
1,215 Posts
NO power or it cuts off at about 3000rpm?
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Its not the rev problem. When I jump the relays it starts and runs fine. It seems like I'm not getting a signal from the ecu when I turn the key on.

Actually had two problems. Initially I had no power to the relays. That was an error on my part (forgot to reconnect a plug under the fusebox by the battery). Pretty sure I'm not missing anything at this point.

Any pointers guys??? Wonder if something is scewy in the harness. I got it from Mike U and have heard bad things about his work lately. Oh yeah it took like eight months to get my harness done. So kinda wondering...
 

·
Banned
Joined
·
3,235 Posts
yea, the main ecu power is a black red medium sized wire that come off that big ass grey plug next to the ignitor. if u dont have that goin to the key on power then yea, your ecu wont have power.
make sure u do a continuity check to see if u have the right one. its accually alot of key power points though ou the intire harness. goo luck. u need any helplet me know.

and juss so u know 86.5-89 cahssis have different chassi wireing.
 

·
Ronin
Joined
·
1,215 Posts
does everything come on, it just wont start? or is there no power whatsoever, like lights and stuff dont work?

and out of curiousity.. did you use the jza70 tach?
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #7
The car powers up fine. It cranks over just like it should. I'm just not getting a signal to the EFI relay telling it to switch. Which in turn does not send any power to the switching relay under the right kick panel. Which in turn does not power up the fuel pump relay. When I jump the EFI relay it sends power to the switching relay but still no signal to cause the relay to switch. So I have to jump that one too. Then the fuel pump powers up. Otherwise everything powers up and works. Hell the car even idles nicely!

I'm sure its something simple. Didn't mess with tonight.

On the tach thing I used a 7m turbo tach with the face of the jza70 tach. Don't think the jza tach would work to well with my cluster. The backs of the tachs are slightly different.
 

·
Banned
Joined
·
3,235 Posts
IF YOUR CARS A 90-92. then there is a plug on the passenger side, that looks like a plug for the fule pump. it chillen where the air filter used to be. conect the two power ons to the fule pump relay, so the efi relays click on when the key is in the on possition.

i forget what colors thy r.u juss have to check it with a multi meter.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #10
My car is actually an 88 model. I guess this weekend I will dedicate some serious time to the wiring diagrams and an ohm meter. If nothing else I'll get the intercooler piping welded up and limp the car to work on monday. I'm sure my boss will be a able to figure it out as I'm no where near as sharp when it comes to eletrical diagnosis...

Any other ideas guys???
 

·
Registered
Joined
·
5,231 Posts
Hey Broken!!

I am in a similar spot....just haven't had time to mess with it lately. I have to jumper the fuel pump, to get it running. I can pull the jumper once it's running, but it'll only idle. If I try to accelerate it dies on me, so I know that the pump's not getting a signal, etc. I have to leave it jumpered (running VERY rich), to move it in and out of the garage to work on it.

I still have a couple more connections to make at the junctionbox connector for the Main/EFI relay and something else. Very close to finally being complete, but have very little time on my hands. Might put a few hours in this weekend tho. Email me offline and maybe we can compare some notes....

http://home1.gte.net/res0g2t7/index.html

Elvis
 
1 - 13 of 13 Posts
Top