Supra Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
402 Posts
Discussion Starter · #1 ·
Alright last night i was driving along and took a right turn and my check engine light comes on so i drive home thinking tommorow ill fix it, well i get the code up and i finnaly got it erased cause it was a error saying somthing was unplugged but it wasn't.... Now today! i am driving along and all of a sudden the add oil-battery-and "bulb" light and center caution triangle turn on yet the car is still running fine all day... all the dash warning lights some times stay on for a while, some times there all off, but heres the wierd thinkg they all "flicker" really fast together like some wires are touching but i cant figure this out! Any one got ideas.....

Alright that question #1

Question #2

Since i bought my car the powersteering has been making alot of noise, we changed most of the fluid thinking it would help but it didn't the noise sound like its coming from where the pulley is should i just replace it or is there somthing inside that might be making that noise....

If any one could help me out in ether of the problems i would greatly appriciate it Thanks a ton Derek D.
 

·
Registered
Joined
·
402 Posts
Discussion Starter · #2 ·
Any one?
Also it seems like the lights only flicker when the car is moving and at running optimal running temp....
 

·
Registered
Joined
·
402 Posts
Discussion Starter · #4 ·
crossways said:
What was the initial error code you pulled?

Maybe your alternator is going.
The initial code was MAF Circuit Voltage High but we cleared it and it then stayed gone .... Then this problem, occured i had other people look at it today and they said that it probably is my alternator to...Ive cleaned the battery terminals, grounds etc.. still does it.... Ill guess i order one from toyota and see what happens thanks cross
 

·
Super Moderator!!ON PATROL ALL OVER!!
Joined
·
10,459 Posts
Insported said:
The initial code was MAF Circuit Voltage High but we cleared it and it then stayed gone .... Then this problem, occured i had other people look at it today and they said that it probably is my alternator to...Ive cleaned the battery terminals, grounds etc.. still does it.... Ill guess i order one from toyota and see what happens thanks cross
speak to member obiwan he has i belive some good used ones for sale .at a decent price ,if not talk to curt aigner from elhurst toyota he can sell you a new unit cheap.
 

·
Registered
Joined
·
967 Posts
I had the flickering lights and it ended up being the alternator, you can test the alternator to see if it is putting out the correct charge too, eventually my lights just stayed on. Make sure all the connections are clean and tight, but it sounds like the alt. is going.
 

·
Registered
Joined
·
1,081 Posts
Q1: Hook up a Voltmeter to the battery and run your engine (open up the throttle)....you should see around 14V or around there and not just 12V+...meaning your alternator is not crapping out on you. Most likely your problem unless you have bad wirings somewhere.

Q2: Are you loosing fluid?..is it a belt like squeek or something else? Cause it may be as simple as replacing the belt...otherwise your power steering unit may be heading out.
 

·
Registered
Joined
·
402 Posts
Discussion Starter · #8 ·
HmoobSUPRA said:
Q1: Hook up a Voltmeter to the battery and run your engine (open up the throttle)....you should see around 14V or around there and not just 12V+...meaning your alternator is not crapping out on you. Most likely your problem unless you have bad wirings somewhere.

Q2: Are you loosing fluid?..is it a belt like squeek or something else? Cause it may be as simple as replacing the belt...otherwise your power steering unit may be heading out.
I replaced the alternator today and havn't hed problems YET hopefully it will stay that way thanks for the help all.

No fluid lose but is there supposed to be a certain color cause mine is like a deep orange-red color.....No belt squeek and yeh thats what i was thinking... oh well
 

·
When cars say, "NO MORE!"
Joined
·
2,112 Posts
if a power steering motor is going bad changing fluid wont help it. That is probably what it is. The other cause of dash lights flickering would be a bad ground.
 

·
Registered
Joined
·
967 Posts
glad to hear you most likely fixed it, the lights would have come back most likely if it wasnt the alternator, I had the same exact problem and it was the alt.
 
1 - 10 of 10 Posts
Top