Supra Forums banner

1 - 5 of 5 Posts

·
Dsm killer
Joined
·
339 Posts
Discussion Starter #1
I tried to install my greddy bcc last night and failed. I know it isn't that hard and I believe my connections were poor, I had too big of butt connectors and that probly was the cause. Where do you guys ground at? Also I hooked my TPS back to the ECU so everything was back to normal so I could get home and start today on it and the car is going crazy....Engine light comes on trac light comes on and it was running rough and it finally stalled and won't start. I did have to put a wire between the TPS wire to connect to the ECU because it was too short. I sorta patched it w/a wire. Can someone help me and do you think that i just have poor connections and im throwing the ecu off?
 

·
Registered
Joined
·
1,095 Posts
Buy a fields harness (replica) from MVP, take your time and do good soldering and you will be set.
 

·
Registered
Joined
·
151 Posts
do it as the mkiv.com.site says and you won't have a prob i've installed a few of them, ground it on a screw adjust the inside sensor clockwise a 1/4 turn to minimize lag and get a better volt response for fuelling, good luck
 

·
Dsm killer
Joined
·
339 Posts
Discussion Starter #4
Ok i believe she's working now :) thanks everyone.
 

·
Registered
Joined
·
61 Posts
Take MCOSKI's advice & buy a Fields Harness replica from MVP. This will make the rest of your electrical mods easier to install. You can make more reliable connections with the harness.

You have the highest quality vehicle made, keep up this standard with your mods.
 
1 - 5 of 5 Posts
Top