Supra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter #1
Hi,

I have the Profec E-01 in my car. I was never all too happy with it, as the automatic function never worked.

Now I have upgraded my Turbo und Intercooler and Hardpipes,

When switching it off, it will do about 0.4 bar (5 psi) which is about stock on the upgraded turbo.

Wehn switching it on, the automatic setting still won't work and on the manual setting i get about 0.9 bar (13 psi) with the settings 45 gain and 45 set. If i go higher on the set value the pressure drops, if I set it lower it will drop as well.

I'm thinking of selling this carp boost controller, but does anyone have some help?
 

·
Not so boring anymore
Joined
·
7,085 Posts
you sure the solinoid is hooked up correctly.. we were having problems with my friends car Turns out, the solinoid was hooked up wrong.
 

·
Registered
Joined
·
1,877 Posts
I'm not sure about that particular Profec but did you recalibrate? On the older ones you had to with any turbo change or change of pressure routing including the IC.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #6
That could be a reason as i upgraded Turbo, Intercooler and Hardpipes.

Although the Auto mode anyways never worked, so I used the manual all the time. I have it set to the following:

Set 45
Gain 45
Start Boost 0.50 Bar

This gives me aroud 0.85 Bar (13 PSI). If I increase the set value, the boost drops, if i decrase it it drops aswell.

Is there any recalibrating necessary if i was running in manual mode?
 

·
Registered
Joined
·
1,877 Posts
McMsk said:
That could be a reason as i upgraded Turbo, Intercooler and Hardpipes.

Although the Auto mode anyways never worked, so I used the manual all the time. I have it set to the following:

Set 45
Gain 45
Start Boost 0.50 Bar

This gives me aroud 0.85 Bar (13 PSI). If I increase the set value, the boost drops, if i decrase it it drops aswell.

Is there any recalibrating necessary if i was running in manual mode?
I would think so. That is the case on mine but I have the older Profec A. I've always run it in manual mode. Then again, it's electronic with fuzzy logic and I'm not sure what the architecture is with yours. I have to calibrate mine so it knows turbo boost pressure and manifold vacuum pressure. That all changes with upgrades of turbo etc.
 

·
Registered
Joined
·
230 Posts
Discussion Starter #8
ok, I will check out how to recalibrate it and give it a try. Otherwise I'll go with a manual Boostcontroller (bleeder valve) as that always worked fine.
 
1 - 8 of 8 Posts
Top