Supra Forums banner
1 - 20 of 33 Posts

·
Registered
Joined
·
1,775 Posts
Discussion Starter · #1 ·
Years ago i did my na-t conversion, i took many shortcuts and ended up with the car being as fast/slow as the NA version, but it didnt give me any problems during 3 years and i was ok with that to an extent after i decided not to spend more money on the GE motor.

Last week the battery died, it was leaking coolant, the transmission started slipping bad and it ended up overheating and messing up the water pump and some pipes, that was it for me, i bought a car cover and started saving for a full swap. The car can be fixed but i made up my mind and i dont want to spend a single dime on the GE motor.

I will post pics here, blacksupra97 will be my right hand through the whole ordeal ( hopefully ) but if we feel lost at any point i will post my questions here. thanks in advance :run:

Nothing going on now, just removed the battery and put the cover on, waiting for the motor and parts


 

·
Premium Member
Joined
·
1,169 Posts
i guess a TT swap is just but right since even your transmission is now missing .. way to go .. good luck
 

·
Registered
Joined
·
1,775 Posts
Discussion Starter · #11 ·
thanks guys, ive been getting all the parts ready, including all the essential tools, heres what i got so far
engine stand

engine hoist, dad giving me a hand

auto tt usdm transmission with crossmember, did some research and decided to buy this instead of messing with the auto jdm.


i bough a tt driveshaft, its on the way, usdm auto tt harness on the way, engine still on hold, should have it around 6/20 hopefully. will post pics as soon as i get more parts in.
 

·
Registered
Joined
·
1,775 Posts
Discussion Starter · #13 ·
I didnt give up, but don't expect big parts or clean work, I painted the bay myself, took the motor out with the help of a friend, did all the work of removing parts from the na myself and had 97blacksupra do all the work on the gte. All these pictures were taken during 7 months or so, I didnt take that many pictures since my time to work on the car is very limited.

I'm still working on the car but wanted to update the thread and ask some questions too.

Removing the ge



nasty !

how i feel about this motor

removing the oil pan


finally

a whole day to remove the turbos, this was a pita

cleaned the best i could

na oil pan in the gte


break
 

·
Registered
Joined
·
1,775 Posts
Discussion Starter · #14 ·
turbo


dont mind the carbon fiber, i riped it off after the picture

did all the work on the harness myself

ugly color combo but not bad for a good deal on 850cc

ready to go in

took a while for this moment, but still not done
 

·
Registered
Joined
·
1,775 Posts
Discussion Starter · #19 ·
its looking good man, look foward to the updates
Thanks , Will post more pictures in a little bit

looks great!
Yeah! cant wait to finsih it

What all are you taking off from the na-t? As far as fuel support and a wastegate/dumptube and stuff? Pm meif you're interested in getting rid of a couple things.
I sold the old injectors, gave the manifold and wastegate to a friend, sold the old turbo, basically sold everything on ebay.

awesome story bro, im in the same exact boat as you.. going from NA-T to GTE swap. its being done right now, ill be sure to let you know how it turned out

good luck!
thanks! best of luck to you too, will keep you guys updated with the numbers and daytime pictures when i get a chance.
 

·
Registered
Joined
·
1,775 Posts
Discussion Starter · #20 ·
NEED HELP

This is a Jdm motor, Im using a usdm harness with modified wires for the na fusebox, everything plugged in perfect except a few plugs.

I dunno what this plug is, anyone?



This is a female plug on the intake manifold, but nothing on the harness plugs into that.... maybe is that blue plug but only works on the usdm intake?
can anyone confirm?


What do you call the bolt and small metal pipe that goes here? I need to ask curt for this piece but dunno the name.



I assume this one is for the resistor box? If so I'm running high impedance 850c with aem, after some research I found out I dont need the resistor pack if Im running high impedance, but I didn't find anything about leaving the plug like that. Can anyone confirm?



This thin black wire, I believe is a ground but is cut, what does it hook up to?

 
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top