Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
442 Posts
Discussion Starter #1
I have a spare H.I.D. Xenon replacement ballast. I purchased it to replace the Philips LVQ 212. I purchased it thinking I messed up the last one but that wasnt the problem. I never installed it, some how the system reset itself. If you have any questions feel free to email or call 757-581-9018. $75

The specs are:

Volts in ....9-16V
Volts norm13.2V
In norm.....3.2A
In max.......20A
P out..........35W norm
T case.........-40c --- +105c


 

·
Newbie
Joined
·
1,070 Posts
What do you mean the system reset itself, on your original ballast or this new one?

I actually have a Philips kit and I need a replacement ballast. Will you take $65 shipped?
 

·
Registered
Joined
·
442 Posts
Discussion Starter #4
I never hooked up the new one. I took the one I thought was bad and swapped sides and it worked so I put it back. From the research I did, I read the the system only reset itself a few times before it finally takes a crap. Since toyota uses negative triggers you cant let the unit touch your vehicles chassis or it will short out. Thats why Philips and other companies offer special holders for the units. Hopefully this info will help you. I payed $90 last week shipped so Im trying to get some of my money back. If not Ill keep it as a spare.
 

·
Registered
Joined
·
1,507 Posts
That's a hela balast correct? Photo of the label side?
 

·
Registered
Joined
·
76 Posts
^^ that actually looks like a "hella" look-alike.

Hella never made ballasts with those aftermarket 2 plug bulb connectors. Those are generic made ballasts that resemble the Hella/Philips ballasts.
 

·
Registered
Joined
·
442 Posts
Discussion Starter #7
Those connectors are an option. It has those cause thats whats the philips sytem I have uses but the D2S and D2R connection was an option thru the company aswell.
 
1 - 7 of 7 Posts
Top