Supra Forums banner

1 - 11 of 11 Posts
N

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I just had an Apexi AVC-R and a Greddy BCC installed on my 94 automatic Supra TT. When we were driving the car we set the boost to 1.2 bar and upped the duty cycle too, but the power seems to be surging between 3000-4000 RPM. It is almost like the power dies off and picks up about two times... kind of strange, I am new to this whole thing but my mechanic knows something is wrong.

If we decrease the boost pressure and the duty cycle it works better but we lose power. Same if we turn off the boost controller, the surging goes away.

Any advice as far as settings go or what might be the problem?

I also have an HKS SSBOV and Apexi S-AFC 2 installed.

Thanks again!
 

·
Lets go Nets
Joined
·
2,956 Posts
well i have an BCC and AVC-R, the boost sorta hits you with a boost controller, all of the sudden its like boom at full boost, without the boost controller it builds more gradually and slowly.

Brett
 

·
Premium Member
Joined
·
10,090 Posts
Advice: Sell the AVC-R for whatever you can get for it and buy a boost controller that works! :)
The AVC-R on stock twins is a terrible combo, lots of SF members have problems with it. I had a problem similar to your when I tried this unit years ago...I never solved it.

Regards,

Dusty
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Well, I was thinking of going Single Turbo down the line and I did sink a good amount of money into installation for it as is... only reason I don't want to give up hope just yet. Do you know if going single will be more compatible with the AVC-R?

Thanks again for the advice and for the great deal on the HKS coilovers too Dusty! =)

-Kimo
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Oh, I read somewhere recently that people had problems with their stock wastegates that were causing problems similar to what I am having. Does anyone know if adding that external wastegate spring will solve the problems that I am having?

Thanks again!
 

·
SAP R/3 Guru
Joined
·
834 Posts
Just a thougt Dusty if AVC-R is so bad why are you selleing it at your site ?
 

·
REVTECHRACING.COM
Joined
·
2,675 Posts
i had the same problem til i put the turbos in ttc mode then all went away.i have the same combos u do. the avc-r doesnt work good in seq turbo mode. hope this helps.btw i wired the the actuators open instead of the ettc method.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Some people have had good luck with this controller. I think it's a piece of shit. I went with the EVC5. Much better, holds boost like a mofo.. Spools faster on my 63 w/ the evc than with the acr too. Not to mentinon I don't have to worry about boost spikes :)
 

·
Lets go Nets
Joined
·
2,956 Posts
quicker spool eh? I like the gauges on the AVC-R, I wouldn't give up peak/hold for boost, rpm, and injetor%. I do have trouble with the spool though...

Brett
 

·
SAP R/3 Guru
Joined
·
834 Posts
Thats true, so it works good with singles then ?
 
1 - 11 of 11 Posts
Top