Supra Forums banner
1 - 12 of 12 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I am looking at buying a supra, it's for sale for around 1k, has 209 miles on it, and this is the email I got from the seller.

well i dont anything about any imports. im a chevy v8 guy. im just selling the car for my brother. it has 209k miles. the top of the head sounds like its running dry, like its not getting any oil up there, its making a tapping noise. thats why we think its the oil pump. we've looked at alot of sites online and they said its probly the head gasket but its not running hot, and not mixing water and oil, and it starts and idles fine, just sounds dry. and as far as we know its not had any motor work done besides the tune-up kinda work. ill have to go over later today and take some pictures to send you, i wasnt expecting anyone to write back this soon. thanks
What do you think?
 

· Registered
1989 7mgte swapped mk3
Joined
·
1,500 Posts
My car does this "tapping" on startup, but no other time. The stock gauge reads really low, but I put a manual gauge on it and tried it out and it read according to the TSRM. Is this tapping for a few seconds on startup harmful in any way?
 

· Banned
Joined
·
5,915 Posts
If the whole head is making noise, than the engine needs an oil pump...and who knows how long the car has ran without oil pressure. Nobody knows what those bearings look like.

And since you just about have to tear down the whole front of the engine and lift the engine off of the subframe, you might as well do a full rebuild.

If you say the body is nice and straight and the interior can be cleaned, then I would offer the guy $500 for a shell.
 

· Registered
Joined
·
296 Posts
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top