Supra Forums banner

1 - 8 of 8 Posts

·
488ci V10 Power
Joined
·
1,785 Posts
Discussion Starter #1
hey guys,

a couple weeks ago i installed my BCC and when i installed it with the fields ECU harness i noticed i installed it wrong and wired a couple wires wrong. Well i figured it out when i couldnt set the BCC to 4.1v and i corrected it.

ever since then both my turn signals are dead. the lights inside for them dont work and the outside lights for them dont work.

i checked all the fuses in the engine bay and the drivers side fuse box, everything was ok.

where do i go next. Im assuming my BCC is installed correctly because i have the BleederT mod and have NOT seen boost cut at all.

thanks guys
 

·
Supra OG
Joined
·
1,002 Posts
Did you open up your dash for anything else coincidentally?

Check if the hazards work. If they don't... unscrew and pull off the top part of the dash that has the hazards button.... i bet the hazards button isn't connected. the turn signals go through that harness as well.

Andi
 

·
Registered
Joined
·
118 Posts
Check to see if the turn signal flasher is good. The flasher is a metal switch, and when it heats up it opens the circuit, therefore making the turn signals blink. If this switch (flasher) is bad it will keep the turn signals from working. I'm not sure on the Supra, but usually the turn signal circuit has two flasher. One is for the turn signals and the other for the hazard signal. What you can do is remove the hazard flasher and install it in the turn signal circuit. Hopefully that’s the problem. I don't know were the flashers are located, but they are usually by the fuse box in the car.

Later
 

·
DitchByTheSideOfTheRoad
Joined
·
485 Posts
Andi said:
Did you open up your dash for anything else coincidentally?

Check if the hazards work. If they don't... unscrew and pull off the top part of the dash that has the hazards button.... i bet the hazards button isn't connected. the turn signals go through that harness as well.

Andi
hehe...i did that one before...go to signal with Peter following behind me...wtf? no signal?

Take it back apart the next day...sure enough forgot the hazard.
 

·
Super Moderator
Joined
·
46,550 Posts
Parham said:
I'm not sure on the Supra, but usually the turn signal circuit has two flasher. One is for the turn signals and the other for the hazard signal.

Later
Supra's only have one flasher.It controls the hazzards and the turn signals.The turn signals and the hazzard bulbs are one and the same.

Part# for flasher-#81980-12070
 

·
488ci V10 Power
Joined
·
1,785 Posts
Discussion Starter #7
Hua said:
Why are you running bleeder T in addition to a boost controller?
The parts listed are sitting in my garage still waiting to be installed! :D

and everyone, YES! my dash was apart. i installed the Valentine1 through the dash and i bet i forgot a plug some where.


thanks guys!
 
1 - 8 of 8 Posts
Top