Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1 (Edited)
Has anyone had this happen to them?

I was driving from 1st into second, when all of a sudden, I realized the clutch did not come back off the floor with my foot. It was stuck to the floor! :(

I pulled over.

I can pull the clutch pedal from engaged back out with no problem. I looked closely from inside the cabin, and the pedal spring and setup is ok.

But something happened. The clutch was solid up until now. I can't imagine the clutch is worn out.

What happened? Where can I start looking?

1) what can be my troubleshooting points?
2) could it be the slave cylinder?



tks
Ron
94tt6sp
 

·
Registered
Joined
·
248 Posts
this happened to me lately. Check your hydrolic level. Check to see if there is any leaks. If all of that is ok, get under the car and take out the bolts of the service plates on the bell housing. Look in there and see if the release fork support broke or not or what not (mine broke). also check your release cylinder as well.

gl,
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
with more investigation....

I jacked the car up, it appears there is fluid onder the engine bay... I checked the hydrolic fliud and it's empty!

Now what?
 

·
Registered
Joined
·
248 Posts
why don't you just poor some brake fluid in your reservoir and have someone pump the clutch and locate the source of your leak.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
No apparent leaks. When we filled the tank up, the level didn't move or go down. I pumped the clutch many times, and it still didn't do anything... and the color changed to a dark color.

The slave cylinder looks ok. Perhaps the seal in the master cylinder broke off inside?
 
1 - 7 of 7 Posts
Top