Supra Forums banner

1 - 10 of 10 Posts

·
supraman
Joined
·
632 Posts
Discussion Starter #1
I just installed the custom made polished SS front pipe to my HKS midpipe. I took a drive and was shocked what a difference removing the precat can make. It was a lot louder too. Excellent pull between 2000 to 4500 RPM But on second gear at about 5000 RPM the car started jerking and almost cuting off-- like something was preventing it from reving. I was quite dissapointed as this cut my power down and slowed me from reaching the magic 7K fast. Is this the boost cut or what? I have just ordered for a Greddy BCC.

 

·
silvermkiv
Joined
·
448 Posts
Yep, should have seen all your warning and indicator lights flashing on the dash as well. They could charge $1000 for the bcc and it would be worth it to avoid that cut ;)
 

·
supraman
Joined
·
632 Posts
Discussion Starter #3
No! Actually it was jerking and the power kept coming on and off from 5000 on the way to 7000 RPM? Did not see indicator lights. ;)
 

·
silvermkiv
Joined
·
448 Posts
Try turning off your traction control or better yet pulling the fuse. It's the 4th fuse from the right (7.5 amp) on the second column.
 

·
Banned
Joined
·
4,144 Posts
It doesn't sound like your're loosing traction, but it does sound like the spark plug gap may be too high. Try gapping them to anywhere from .030 to .026. It should help.

Eric
 
W

·
Guest
Joined
·
0 Posts
If you do not have the BCC on than do it. It sounds like thats the problem. It is WORTH the xtra 100 bucks. Oh yeah, when you get it and you are installing it, make sure you know what you doing. You do not want to mess your ECU up. I have seen people clip the wrong wires before and it turned out to be a big hasle. It's pretty easy but DON"T [email protected]# UP!!:D
 
F

·
Guest
Joined
·
0 Posts
I have this too! I have a BCC but I didn't tune it. I'll try to diagnose more tomorrow.
 

·
supraman
Joined
·
632 Posts
Discussion Starter #8
Cowboy! You are right the car is missing and sort of back firing @5000RPM due to spark plug gap I just realised we gaped it at .050 the last time, too big a gap? Will gap down and check if it happens.:D
 

·
Banned
Joined
·
4,144 Posts
Wow, .050? That's a pretty big gap. Yeah, I'd say if your dash lights aren't firing off then try the spark plug gap first. It's just cheap insurance.

Eric
 

·
supraman
Joined
·
632 Posts
Discussion Starter #10
Will do and post again. thanks friend!
 
1 - 10 of 10 Posts
Top