Supra Forums banner

1 - 3 of 3 Posts
V

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Ok, We were working on Euphoric's car tonight, we got it running, and idling nice and clean w/ the SFC and VPC both set to 0. Off idle, if you punch it, it revs quickly and does fine, if you try to just roll the throttle on, it stumbles a little untill it hits 2000-2500 or so, then cleans up... Any ideas? I'm thinking it may be because the plugs are fouled... basically the car ran for 15 minutes (total over a couple different starts) Just dumping raw fuel out the exhaust... Could fouled plugs cause this? Any ideas??? Also, he's got an Autometer Silver faced A/F Gauge (w/ the ring of LED's aroudn the outisde) and it bounces around like crazy... (goes up to one particular point, I'm assuming how rich/lean it's actually running) then bounces back down to the bottom... I've heard the gauges like to bounce like this... should we just accept it?

Gracias yo.
 

·
Registered
Joined
·
989 Posts
It could be the plugs or a vacum hose(check both). Don't worry about the a/f guage bouncing all over the place that's normal. It only works when you have it wide open throtle. It should be reading at least one bar green but, don't trust that gauge it's garbage. People have blown motors with that gauge reading rich. I don't think you'll have a problem if your running stock twins.
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Hmmmm... Yeah I didn't even think about vacuum leaks... Have to check those later I suppose! Thanks for the input! Anyone else?
 
1 - 3 of 3 Posts
Top