Supra Forums banner

1 - 20 of 29 Posts

·
Nottin' like boost...
Joined
·
1,378 Posts
Discussion Starter #1
Alright I am starting to get really frustrated with my car...I love when it works perfectly but it hardly ever does...here are some of the problems i have....there are more then one

1. It was boosting great, had a mbc set at 17, felt really fast, everything was great. I went home for the weekend so i didnt drive my car, get back in it, now at the same setting it was doing like 13 lbs at the most, with it all the way closed the car was struggling to get 17lbs, etc, its all over the place but mostly lower then it should be. So i installed a profec b thinking maybe it was the manual boost controller, it isnt, with the knob all the way turned up on the low boost i hit 17lbs of boost, sometimes less...is this a boost leak? Btw it was like low 60s just now and sometimes it would fly to 20 psi on the high setting turned all the way up and then i would let off, sometimes it would struggle to get to 15, sometimes it would boost perfectly, sometimes it would build boost too slow and not enough of it. Its not the boost controller because the same thing happen with the mbc and the ebc. The profec b testing was on a short 15 minute drive after i put it in, with it turned off once it went to 15lbs, the other time like couple minutes later it would only go to 10lbs. I have no clue what is going on, but it sucks, the car does not feel as strong at all more the half the time. Out of the 15 minute drive it boosted perfectly for like 2 of them...

2. I can hear the rotors on my brakes lightly rubbing on my brake pads when I am passing by a building or a car, hopefully this can be solved by just pushing the pistons in a little bit more? since i just got new rotors on....

3. Everytime I let off the gas, at 20,30, 40mph i hear a rattling that goes away and also some high pitch sounds that sound like one of those wind chimes, it does this just right after i let off for a second, it doesnt do it the whole time im decelerating, I am not sure if it does it at higher speeds because its too loud to hear it. The rattling sound started a little while ago but the semi high pitch sounds that sound like a wind chime going off just started a week or two ago

4. when i rev, when I let off the gas i here a rattling too, is this a downpipe that might be loose? i had this problem with the car from the beginning when the car just had a downpipe, i kind of assumed it was that but just never got around to fixing it

Thats all i can think of right now but it is really starting to get to me. It is actually making me think of selling my car

Its not like this car is a crazy single turbo or anything, its just a plain ol bpu car, i always thought it should be at least semi reliable

if you have any suggestions for any of the problems I have please feel free, right now im just tired of it
 

·
Registered
Joined
·
1,421 Posts
Wow, that all sucks. The boost thing is wierd since it is so inconsistent. I bet it could be a boost leak, a sign of the turbos going , or maybe even a bad wastegate (doubt it because of inconsistancy). Do a boost leak first since that could be an easy fix. Try putting the car in TTC too. I doubt it is something with the sequential system but it will only take a couple minutes to see if the car boosts better.

As for #4, its probably and exhaust leak. Hell, maybe #3 could be too. Just get the car on a lift or jack stands and have a friend rev the engine whilke your under the car. It will be easy to tell if you have an exhaust leak. Good luck, I hope everything works out for you. :)
 
R

·
Guest
Joined
·
0 Posts
Dude you do nto understand I am in the same boat as you its so damn frustrating.

I have a boost problem too but the opposite of yours I cant hold boost for shit its all over the place.

As for the strange noise I dont know if this is the same thing but sometimes my car does not wanna boost and when I let off the gass I hear a starnge high pitched boooooo sound?

Is that the same thing???????
 
R

·
Guest
Joined
·
0 Posts
You know what I am almost ready to sell to I am trying so hard to figure this shit out and spent so many hours trying to fix it.

What pisses me off the most is that i just spent another 1k on a 3-row and the damn car cant even be driven hard because it will over boost like a mother.

Last night I took it out and the interior lights would go dim and the car would stumble and was not pulling hard at all even after I reset the ecu.

Another problem that started a week ago is the brake pedal gets hard as a rock and as your trying to apply the brakes the peddal bounces up and down???????

The car only has 39k miles on it???????

Sorry guys jsut venting
 

·
Registered
Joined
·
3,559 Posts
instead of just having the bleeder-t vavle there, or a MBC, just completly cap of the other side so NO air gets to it. All the MBC is doing is bleeding air from going into it.
 

·
Wheelhophobia?
Joined
·
466 Posts
Stang, if it's a six speed, sell it!!!! I know someone who will take it off your hands for the right price even with those probs!!! j/p unless your serious.....
 

·
Registered
Joined
·
2,365 Posts
replace the stock turbos and wastegate this will fix your problems, sounds like the BOV is not letting the boost out and your waste gate is opening and closing funny. replace with a good set of used ones and you should be fine.
 

·
Registered
Joined
·
1,421 Posts
I think its premature to start ripping out the stockers. Check the small stuff first. Your not getting a death whine or oil leaks right?
 

·
Registered
Joined
·
658 Posts
put it in temporary TTC and see if that makes the problem go away the sequential system is complicated and a bear to trouble shoot. try posting on the mkiv.com list the resouces It has some very knowledgable supra owners/gurus.
 

·
Medium Ballin'
Joined
·
3,024 Posts
Re: Needs tuned bad

supraxotic said:
Sounds like an hour or so is needed on Dyno
huh? no it doesnt.

the rattling could be the downpipe, depending no how close it gets to the firewall/trans tunnel area. seen i thappen before, but usually on single cars.
 

·
Registered
Joined
·
1,255 Posts
do TTC... this is the best way to help isolate problems w/ the stock sequential system... (i know, i've been down the path of different tuners, different solutions, lots of money)
 

·
Nottin' like boost...
Joined
·
1,378 Posts
Discussion Starter #16
i have ettc, no death whines, turbos dont leak any oil, they have about 40k miles on them, today i noticed at full boost it would go to like 13 of boost with the setting all the way up, with the high setting all the way up it would very very very slowly creep up to 17, not even close to how it would do it about a week ago. I dont get it, i dont really boost my car hard lots of times but it basically went from perfect to this, i was just on the interstate and floored it and i found it to be odd that my previous setting of 17 was only producing 13 now, just thought it was a loose screw on the mbc but thats not it....
 

·
Registered
Joined
·
658 Posts
if you have a bad vsv I am not sure that ettc will work properly same thing with a bad prssure tank buy the one way check valves and do a temp TTC
 

·
Nottin' like boost...
Joined
·
1,378 Posts
Discussion Starter #19
dzeiler said:
if you have a bad vsv I am not sure that ettc will work properly same thing with a bad prssure tank buy the one way check valves and do a temp TTC
the thing is when i put it in ettc i can tell that both turbos still come on at the same time so it seems like the pressure tank is doing fine

i do still have to stock bov, i think i need to search first for boost leaks, it was only for a second my car boosted fine, now its staying at too low of a boost the whole time
 

·
Registered
Joined
·
67 Posts
SNOOP said:
Is it possible the stock BOV is not functioning properly? Could be intermittantly sticking open?
This would be my best guess. Do you know anyone with another stocker laying around?

#2...I am of the impression all pads lightly rub rotors. Maybe lift the car and make sure the wheels spin freely.
 
1 - 20 of 29 Posts
Top