Supra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey everyone,

I just got a clean title for my Supra and as I am reversing into a parking spot outside of my home, I roll one of my rear wheels into a ditch and kill (stall) the car. After the car died, I lost ALL POWER. No interior lights, no dash display (my dash is digital), no windows, and no locks. I tried checking the main fuse and all of the other ones and none are blown, and I’ve verified engine ground but I’m not really sure where to go from here. I’ve stalled a few times before and there has been no effect on the electrical system like this. Any sort of help is appreciated.
 

·
Master Shit Fixer
Joined
·
3,779 Posts
Is the battery dead (as in suddenly and completely dead)? Fusable link? Do you have main power at the big red terminal in the fuse box?
 

·
Registered
Joined
·
91 Posts
Grab a test light and test from the battery on down. Maybe a bad battery cable that got wiggled loose/corroded.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Is the battery dead (as in suddenly and completely dead)? Fusable link? Do you have main power at the big red terminal in the fuse box?
It is not a battery issue, I took another battery that was nearly brand new and tried starting the car to no avail. I don’t have any power to the fuse box from what I gather (using a dvom from positive terminal to fuse connections). I’m still looking for more fusable links but the ones I have found so far have been alright.
 
1 - 4 of 4 Posts
Top