Supra Forums banner
1 - 5 of 5 Posts

·
CT12 Destroyer
Joined
·
2,992 Posts
Discussion Starter · #1 ·
Alright so I've been APU for ~ 3-4 months now. The whole deal, injectors, pump, safc, fcd, everything you'd need for a medium size single.

I got the car running with the single, ran good.. for about the first week. The second week. I noticed a CEL on the highway. I milked it home, pulled into my shop and pulled a code 52. Knock, no big deal.... Heres where the fun starts

I crawl under the car, look at all my wiring and connections. All solderd connections, sheilded wire. I unplug them, clean them, make sure the connection is good. Plug it back in, unhook the battery and then drive around for a few min, no code. Next day, I start my car and i back outta my driveway and am driving to the top of my hill when the CEL pops up...

Now its a code 41 and 52. Im scratching my head right now. So I go ahead and drive it, see if it still feels the same. Car feels fine.. I drive for about 20ish minutes and then all of a sudden I'm at a stop light, leave the light in first, Im climbing revs, I hit 3000 and the car starts studdering and shit like a premature fuel cut. I go home, and on the way home it stops.

So now, I still have these two codes, and an intermittent studdering. I just checked my timing. It lines up , up top (adj gears set to 0) and on bottom it is reading 12-13 it looks like above zero. I don't know what it should be :ugh2:

I checked my TPS, Multi meter set at 20K, it reads .12 .. I unplugged it figuring it was gone bad, car started to choke and almost stall. So it's still working but other than those two things, I'm stumped

Anyone encounter anything like this ?

Thanks
Matt.
 

·
CT12 Destroyer
Joined
·
2,992 Posts
Discussion Starter · #2 ·
While I was out diddling with the car, Turns out when my cam gears are at TDC my crank is at 5

How do I fix this.. out of all the things I've fixed on my past supras I've never done timing :scratch:
 

·
Your Neighborhood Pikey
Joined
·
3,341 Posts
Supra Junky 101 said:
While I was out diddling with the car, Turns out when my cam gears are at TDC my crank is at 5

How do I fix this.. out of all the things I've fixed on my past supras I've never done timing :scratch:
You will need to reset your timing belt to get everything on line. That's the only way. It's not hard to do though... Want a write-up?
 

·
Supras are never 'done'
1989 Toyota Supra
Joined
·
601 Posts
Loosen the the tensioner from under the car with a 12mm socket, then you should be able to get it back where it belongs.
 
1 - 5 of 5 Posts
Top