Supra Forums banner

1 - 15 of 15 Posts

·
Savage Member
Joined
·
1,033 Posts
Discussion Starter #1
I got in my car and was raining hard.

Last night everything worked, all though I didn't try the heater or air at all.

So the last time I remember everything working would be Saturday when I went to Centralia.

The vents do not blow out any air. I try low/med/high with all temps. I try auto with alll, push a/c and the recirc. Nothing happens. There is NO AIR coming out of ANY of the vents. I can't hear or feel anything!

I changed nothing electrical; only mechanical thing I did was put 2 bolts onto my turbo elbow.

Help!! It is raining and I have to deliver pizza in like 2 hours... I can't go in if my windows won't stay un-fogged.
 

·
Registered
Joined
·
1,113 Posts
mmm sorry man that sucks ass. i guess your sup isnt running so good. The last time i saw you, it ran fine just slow. :) well have eddie look at it he likes to work on supras.

later

~steven
 

·
Registered
Joined
·
54 Posts
i had the same problem during the winter, put the setting on the front window defrost and make sure that its bringin in outside air...even though there's no fan, it will still bring in fresh air which will help with the fog...if all else fails, get a towel and crack the window...its pretty damn frustrating when ur deliverin and u can't see addresses.
 

·
Offical MkIII Pushman
Joined
·
1,797 Posts
Disced said:
Help!! It is raining and I have to deliver pizza in like 2 hours... I can't go in if my windows won't stay un-fogged.
have u ever deliverd pizza to me?
 

·
Savage Member
Joined
·
1,033 Posts
Discussion Starter #5
I don't know... What is your address? I have delivered to a couple of houses that had supras...

Who knows?

BUT!!

There is no AIR at all coming out of anything.. I put vent on 65 and high with defrost setting and still no air comes out.

I don't know what to do...
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
Oh God man this is sad, i thougth somebody would have an answer by now.

ok dude..your problem is that your fan blower died. duh.

30 bucks to get one at any auto parts store...3 screws and a couple wires to replace them behind your glove box...lil to the right.

simple shit.
 

·
Savage Member
Joined
·
1,033 Posts
Discussion Starter #9
Ok.. Here is the catch.

I checked my fuses before work; the MIR-HTR fuse shows no power, but I put a new fuse in and still no power; switched with one that showed power @ the blinker fuse and didn't show any power... Would that mean the main heater Relay is blown?

Or is it just like you said; the fan is just dead and I should buy a new one?

It is the same for all years; ie 86.5-89 89-92(since I have an 86.5)

Thanks!
 
T

·
Guest
Joined
·
0 Posts
when i had no heat i replaced everything, and still nothing happened, then i finally found out that the cvc pipe (i think its called that) that runs around the head was clogged... that'll do it to ya...
 

·
Registered
Joined
·
945 Posts
lol What pizza company do you work for? I run a Papa Johns Pizza in Jax and used to deliver in my Prelude. I was going to make the Supra my Slow day car so I could save fuel on the busy days. Now I just manage a cpl days a week and short shifts the rest.

Delivery Can put some hard wear and tear on a vehicle. Keep up with Maintainance like you keep up with you own child!
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
Disced said:
Ok.. Here is the catch.

I checked my fuses before work; the MIR-HTR fuse shows no power, but I put a new fuse in and still no power; switched with one that showed power @ the blinker fuse and didn't show any power... Would that mean the main heater Relay is blown?

Or is it just like you said; the fan is just dead and I should buy a new one?

It is the same for all years; ie 86.5-89 89-92(since I have an 86.5)

Thanks!

means your fan blower is dead. If you want..test it out for power.
 

·
Savage Member
Joined
·
1,033 Posts
Discussion Starter #15
Alright. I will trust you JD. I will get one and see what happens.
 
1 - 15 of 15 Posts
Top