Supra Forums banner
1 - 10 of 10 Posts

· Life begins @ 30psi....
Joined
·
3,004 Posts
Discussion Starter · #1 ·
Guys I need some help.

I purchased my new to me 98 Supra last week and I am driving it now. The car is still on stock twins, and to be honest I have never owned a stock twin car before and I have no clue about there operation at all. I will be running the twins for a few months before I go single and want to raise the boost a little bit because the car is a pig right now.

I was told the car is running in permanentTTC, all the VSV's and tubing is all gone. It currently makes about 6psi MAX (.4 bar) and I want to raise the boost to like 12psi or so max but I have no clue how to do so. I can tell you the #1
turbo's boost source is running into the bottom of what I think is the wastegate actuator above the alternator. The upper port is open.

Can someone give me an idea of how to raise the boost?

Thanks,
Bob
 

· Life begins @ 30psi....
Joined
·
3,004 Posts
Discussion Starter · #3 · (Edited)
Do you have a open DP? Because i remember when i put that on, i was hitting boost cut which i think was like 11lbs or something.

Or how about a EBC?
I have nothing I know I am going to need a MBC but I do not know how to route it.

Bob
 

· Life begins @ 30psi....
Joined
·
3,004 Posts
Discussion Starter · #5 ·
A 3" dp is on the car. All I want to run is about 11-12psi?

Do I still need a BCC?

Bob
 

· Slo-vertible Drifter
Joined
·
1,714 Posts
It might be that one of the factory twin turbo values, if not removed, has closed. Or you are hitting boost cut due to some other problem. Does the car start right up everytime?
 

· ex BPU'er
Joined
·
5,973 Posts
A 3" dp is on the car. All I want to run is about 11-12psi?

Do I still need a BCC?

Bob
Bob I was BPU for 8 months, and with the boost controller off, I hit 11 psi no problem (both sequential and ttc). In fact stock boost is ~11psi...

Something must not be hooked up right

EDIT: Stu Hagen's Website has awesome info regarding the stock twins:

http://97supraturbo.com/
 

· Life begins @ 30psi....
Joined
·
3,004 Posts
Discussion Starter · #10 ·
I got it set guys.

I moved the hose from the bottom port of the wastegate acuator to the top port of the acuator and it makes .9 bar / 13psi in 3rd gear with the down pipe. It is still slow but atleast it feels a little better LOL!!

Bob
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top