Supra Forums banner

1 - 13 of 13 Posts

·
what comes out the butt?
Joined
·
4,469 Posts
Discussion Starter #1
Ok, ive been trying to solve this on my own with just the help of some other supra guys over aim...but i have yet to see any luck, so now i ask on you guys..

basically, last tuesday i finally got my BCC hooked up, and then afterwards we took it out and i was hitting 19lbs and tapering off to about 16lbs.....(and i must say, wow that shit pulled)..

when i did this i had no EBC hooked up as i had it unhooked for old reasons and didnt want to rehook it until i had my bcc in, but i had my vacuum lines set up to let me see pretty good boost(obviously 19lbs on the freeway)...

so the next morning, i decide to rehook the EBC because i want to control what im boosting, so i rehook it ( profec b spec 1 ) and im pretty sure its hooked up right as ive looked at the mkiv.com guide many times...

so i take it out, and on the max boost setting the thing wont get past 15lbs, and im just like WTF, continue to play with it with still no luck...

so i say f*** it, and decide to just take the EBC off since i was hitting higher boost without it, but then when i take it off, it wont get over 15lbs still, as to the advice of one of the mods here, i open up the bottom nipple of the front actuator for the open WG effect....the car feels somewhat faster but is still only reading about 15lbs...so i cap EVERYTHING off up front, the vsv, the actuator, the nipple on the front compressor housing...

and thats where i stand now....it hits 14lbs in 2nd...followed by about 16lbs in the following gears...

im aware that i have a boost leak, but im pretty sure its not what is causing me to OUT OF KNOWHERE not be able to boost as high...

any takers on the confuseing motherfucker?

-mike
 

·
2005 LP640
Joined
·
930 Posts
You're setting your boost in 4th gear, right?

As for the boost controller, perhaps messing with the balance could do the trick.

Then check for leaks. If you have a leak, FIX it. That one little leak could be your big problem. It's the little shit that adds up.

Then find someone else because I would be stumped :(
 

·
what comes out the butt?
Joined
·
4,469 Posts
Discussion Starter #3
my ebc came on the car and i got no manual with it, and the mkiv.com profec b instructions never said anything about setting it in 4th gear...so no, no i didnt do that....hmm

-mike
 

·
Registered
Joined
·
1,784 Posts
MaliCali said:
my ebc came on the car and i got no manual with it, and the mkiv.com profec b instructions never said anything about setting it in 4th gear...so no, no i didnt do that....hmm

-mike
i have similar boost problems with my profec b..ive come to the conclusion that this thing is a POS and i will never buy greddy products again...

anyway i have never heard of tuning the BC in 4th gear either...
i used to not be able to keep my boost under like 19 psi no matter what the settings were...and it would go to 18-19m psi and stay there till redline...now after i did some work to the car all of a suden the BC works and i can control my boost again but nowe my boost spikes at whatever i set it at and then tapers off a little bit..it never did this...my car doesnt feel like it has as muhc power as it did before...BTW the work i did was replace the valve stem seals and install a titan cam gear on the exhaust side set to -3 degrees..
i need my top end i gotta race a shit talkin z0-6 owner...i raced him when he was stock and he jumped the gun on me and i stayed with him and he told everyone that he raped me and supras are all peices of shit..and now he wants to race aagin but now he has exhauist and headers and shit..now hes really gonna talk shit...maybe ill jst knock his teeth out so he cant talk


anthony
 

·
2005 LP640
Joined
·
930 Posts
*shrugs*

I set my boost in 4th gear, it's never spiked or had any problems with me.

The balance on the boost controller is key as well to prevent spiking from what I've heard.
 

·
what comes out the butt?
Joined
·
4,469 Posts
Discussion Starter #6
i dont want to prevent spiking, LOL, right now spiking is goood..

im getting the opposite of spike, like it boosts real hard but the boost seems to hit a brick wall at 14-15lbs, as if it wants to keep boosting higher, but it cant...

im really tempted to just take out all of the stock turbos and hardware to them and put them on a table and flip them off and curse at them profusely...

-mike
 
S

·
Guest
Joined
·
0 Posts
What if your wastegate spring was binding up top, allowing you to hold 19psi, but is now free to only hold 15psi? You shoul triple check the wastegate springs.

Also recheck the wastegate hoses. Seems like you did something in the BC install that is allowing boost to escape. Boost leak at some IC pipes? Boost leak somewhere?
 

·
what comes out the butt?
Joined
·
4,469 Posts
Discussion Starter #9
lol^ i was actually JUST TOLD about the spring mod for the wastegate that ill be doing shortly...

anyways..

UPDATE:

i again rehooked the EBC, and reset the ecu ( didnt do this last time :doh: ), and took it out, and before cranking the boost up at all i turned the balance all the way to the mild side...i then took it out, and slowly upped the boost on low boost, and it seemed to be getting higher than it was before, but then once again, would not get over 15lbs...

so then i turned it over to high boost, and on its lowest setting i was already hitting 14lbs when there was more load occuring(it wouldnt do that before)...so as i cranked it i was seeing more and more boost...by the time i got it to the max setting it was hitting 17-19lbs depending on the gear and load i was putting on it...

for example: if i was at 70mph and in 4th, it would spike up to 17-18lbs....while if i started at 70mph and threw it in 3rd id only max out at a tiny bit over 15lbs...

i could also coax more boost out of it by brake boosting(again i wasnt able to do this before) as i was obviously createing more load on it hence seeing more boost...

so basically what this tells me is that, my turbos are fine, the wastegate/actuator seems fine, and the EBC is more than likely fine, and that my problem is in fact lying in that boost leak, or a restriction in the exhaust, i DID forget to menion i still have the first cat in place, as my DP is the HKS shortie dp that only eliminates the 2nd cat...and im pretty sure my 1st cat is the good ole 12 year old factory cat...so that will be getting replaced with a straight pipe shortly...

and as for the boost leak, im actually pretty sure i know what is causing it, as every now and then my car throws an EGR code, that just goes away when i reset the ecu, but will come back randomly when im cruising on the freeway at around 50+ mph....so i have a feeling i actually popped a hose somewhere that COULD be causing a leak as well...

well...GOOD LUCK TO ME!!!

-mike
 

·
Registered
Joined
·
3,623 Posts
Do these three things and a I would almost guarantee you will see 20++psi if you wanted to:

1) Fix any and all vacuum leaks!
2) Wastegate spring mod
3) Get a true downpipe with NO cats
 

·
Registered
Joined
·
952 Posts
let me know what you find cause I am having the same problem. Like you say, if I floor it in 4th at around 70 mph, I would get about 18 psi from 4300 up to 6000 and around 6000 RPM, it would be around 15-16 psi. But if I floor it in 3rd and shift into 4th, I am only able to get about 1.1 bar or 15-16 psi.

I have a wastegate spring on my. I haven't had time to check for leaks yet. So yeah, just let me know what you find out. GOOD LUCK MAN. :)
 

·
what comes out the butt?
Joined
·
4,469 Posts
Discussion Starter #12
^do you have any cats in place?

because i have a strong feeling that my 12 year old cat that is still in place is causing a major restcriction, causing alot of backpressure, which could be the problem...

-mike
 
1 - 13 of 13 Posts
Top