Supra Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
658 Posts
Discussion Starter #1
Hello guys
recently I installed my bpu stuff...exhaust, dp, bcc, boost gauge and a hks evc ez. I checked everything on the evc ez and it looks fine. Its connected right, all the hoses are hooked up...the headunit piece has power. When i turn it on and put the boost to say the middle, where the arrow is on the top i hit 14psi, if i turn it all the way to its highest setting I still hit 14psi, if the boost controller is off I hit 14. No matter what i do i only hit 14psi and I am not hitting boost cut. In the engine bay, the box you install in there, it has a little plastic piece with like a rubber piece covering it. Do i want to get rid of the rubber piece? I think its some type of breather...Anyone experience this? Once i get this fixed I will be installing a egt gauge, safc, turbo timer, fmic, cam gears and intake...

Thanks a bunch =)
Dave
 
K

·
Guest
Joined
·
0 Posts
no leave it alone.. i just installed one... you have the tube with the oneway valve to the pressure side of the turbo and the other large one to the wastegate actuator of the number one turbo.... then the small one to the pressured side like the hose to the intake.... if you need more info email me back... Kevin...
 

·
Registered
Joined
·
207 Posts
Check the rear of the controller. Is there a switch for actuator and external wastegate. For stock twins, it should be set to actuator(AC).
 

·
Registered
Joined
·
658 Posts
Discussion Starter #4
sleeper said:
Check the rear of the controller. Is there a switch for actuator and external wastegate. For stock twins, it should be set to actuator(AC).


ON which controller? The headunit piece that has all the controls to turn the boost up, and to turn it on or off? Theres a switch on there but it doesnt have a thing for AC
 

·
Registered
Joined
·
658 Posts
Discussion Starter #5
Kevin Hornsby said:
no leave it alone.. i just installed one... you have the tube with the oneway valve to the pressure side of the turbo and the other large one to the wastegate actuator of the number one turbo.... then the small one to the pressured side like the hose to the intake.... if you need more info email me back... Kevin...
No i have that right....



On the back of the controller in the car there is a switch for SW or PO
Which should I have it set on?
 
1

·
Guest
Joined
·
0 Posts
did you disable the factory solenoid? did you install it like on MKIV.com by capping off the vsv? If, yes then check for a boost leak.
 

·
Registered
Joined
·
207 Posts
Is it installed like the Blitz DSBC way? Port2 connected to the #1 turbo housing, port3 connected to the top of the wastegate actuator, with the bottom of the wastegate actuator capped. Port1 T'd to a intake manifold source, like the line for the stock BOV.
 

·
Registered
Joined
·
658 Posts
Discussion Starter #10
1/4mile in style said:
did you disable the factory solenoid? did you install it like on MKIV.com by capping off the vsv? If, yes then check for a boost leak.
I dont think we capped off the VSV. I didnt really do the install of this, I helped...but there is a hose where the stock boost controller was that isnt capped or anything.

Say we are looking at the engine bay...you have the spark plug cover and then to the left you have what looks to be like a intake type thing that goes to the 6th cyliner. Its the little metal piece that is like a intake...around there on the top of the engine bay you have 4 hoses...there are 4 hoses....2 go down in to the engine bay...1 of them isnt hooked up...its just dangling there. Should I cap that?


Thanks
Dave
 

·
Registered
Joined
·
207 Posts
If you are in front of the car looking at the intake piping for the 6th cylinder, just to the left of it there are 5 metal tubes that run parallel to the valve cover. Starting from left to right, follow the 2nd metal tube towards the front of the car, this should have a cap at the end(sounds like this is the one that is just dangling with no cap). The VSV for the wastegate actuator(just underneath and in front of the #1 turbo compressor outlet) has 2 nipples, these 2 should also be capped.

Let me know if you need pics, I'll take some tonight when I get home.
 

·
Registered
Joined
·
207 Posts
David,

I had an EVC EZ but I switched to a Blitz DSBC. However the preferred way to install the EZ is the Blitz DSBC way from mkiv.com.

Here is a pic of the metal tube that needs to be capped.

pic#1: capped metal tube(black cap with blue tie wrap)

Location of where Port2 of the EZ goes. I have drawn a hollow eclipse in the pic. Look through this area, you will see the nipple from the #1 turbo compressor housing, this is where Port2 of the EZ goes to.
 

·
Registered
Joined
·
207 Posts
Here is a pic of the VSV that needs to be capped.
#1 and #2 is where the caps go on the VSV and #3 is the cap for the bottom of the wastegate actuator. Port3 of the EZ solenoid goes to the TOP of this actuator. I could not get enough light to take a pic but here is a pic from the Blitz DSBC install.
 
1 - 15 of 15 Posts
Top