Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter #1
Hi Guys,


Have purchased a used HKS triple plate and was wondering if the HKS Triple plate's need a specific Carrier bearing?

Or will the standard carrier bearing be ok?


Any info is appreciated.


Thanks
 

·
Registered
Joined
·
13,569 Posts
if carrier bearing in "english" is the same as throwout bearing in "american" then yes, you need a specific one, not the stock clutch throwout bearing. It's actually the throwout bearing from a MkIII...look on MVP's website (sponsor vendor here) in the clutch section and you'll see a kit described that has those parts along with some hardware.

Btw, I've had my HKS triple for well over 60,000 miles so far and it still works perfectly. A couple observations I have based on others trying it and reports here: if you are not patient enough to learn how to use it, you'll end up hating it. If you learn it, you'll probably never want any other clutch...unless you're a hardcore drag racer.
 

·
Registered
Joined
·
293 Posts
Not sure if this will help, bu here is the manual and it outlines the parts.

http://www.mkiv.com/techarticles/hks_clutch_manual/index.html
I used the part list and bought every item on it but I had a problem with part# 31264-14060. This is a clutch cone spring washer but it is for the 6 speed release bearing and hub and did not fit on the bearing on the list or with the hub supplied. The inside diameter of the cone spring is a little larger and does not line up to the inside ring of the bearing. Instead it sits flush on the bearing seal. Looking at the bearing from the side it's the non metal area. The bearing on the list is part#90363-45012 and according to my toyota parts guy it belongs to a 86 toyota so I ordered the cone spring washer that goes with that bearing that is part#31264-14040. I will know by Monday if that fixes it. If I follwed the parts list to the T, I would have installed the wrong size cone washer and may have ended up with a loose fitting bearing on a hub that would have caused play and ended up giving me more noise than I was supposed to hear.
 
1 - 5 of 5 Posts
Top