Supra Forums banner
1 - 6 of 6 Posts

·
Local Tire Destroyer
Joined
·
1,008 Posts
Discussion Starter · #1 ·
hey i have the gs341 wlabro high pressure 255 plh in tank pump, and i plan on running somwhere around 600 hp. I have a Trust TD07 single turbine kit, and 850 side feed injectors. I will be using a 50 shot of gas to spool up, and am running a standalone EMS. Do you think that the one pump will be fine, or should i buy another 255 lph and run a pair?
 

·
GT40 1.5JZ
Joined
·
1,210 Posts
600 rwhp, you should be fine running the walbro @ 13volts I believe. Check out the voltage maps for fuel pump comparisons. I know that the stock mkiv will flow 550 rwhp @ 13 volts, so I'm sure that the walbro can too. Just don't forget to upgrade your wiring.

-joseph
 

·
Republican
Joined
·
8,421 Posts
600 hp is cutting it VERY thin for a walbro... buy 2 and make a correct fuel system. why skimp on such an important part?
 

·
Registered
Joined
·
330 Posts
Last time I dynoed a high HP walbro, It was having issues maintaing a good constant pressure above about 435 rear wheel.........have video somewhere
 

·
Local Tire Destroyer
Joined
·
1,008 Posts
Discussion Starter · #5 ·
pumps

sounds good guys, i have 2 of those puppies in the tank now, and they seem to pump like mad..

i wanted to drain the tank, and they were filling buckets quicker than i could go pour them out..:)
 

·
Registered
Joined
·
923 Posts
on the subject of fuel pumps, I need to pugrade mine. I'm aiming for 450 rwhp or so max, for now. How do the walbro392s compare to the 255s? the 392 isnt a whole lot more than the 255s.
 
1 - 6 of 6 Posts
Top