Supra Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter #1
Just wanted to know if anyone ever had their resistor pack fail on the blower fan.

Can't get my blower fan to work on low setting so the spiral resistor has broke.

Since these resistors aren't the conventional ones we see in electronics, does anyone know if this can be repaired?

Thanks guyz
 

·
Street Sleeper
Joined
·
1,114 Posts
They can be repaired but its fiddley and not guaranteed to work, just buy a new one from Toyota they are pretty cheap.
 

·
JZS161 Aristo TT
Joined
·
881 Posts
Just wanted to know if anyone ever had their resistor pack fail on the blower fan.

Can't get my blower fan to work on low setting so the spiral resistor has broke.

Since these resistors aren't the conventional ones we see in electronics, does anyone know if this can be repaired?

Thanks guyz
Bridge with single strand of wire solder in place :bigthumb:
 

·
Total Performance
Joined
·
60 Posts
Bridge with single strand of wire solder in place :bigthumb:
I wouldn't do that...

Get a new resistor pack from the dealer...mine was only about $32.
 

·
Registered
Joined
·
223 Posts
Discussion Starter #5
I tried the solder at one point but had no luck, i think the material on the coils doesn't like to bond with lead. The price to replace one is 56 CAD, which is a bit high for something simple, but I might just pull a used one from a parts car unless I find it cheap. Second one in 2 years I've had to replace.

I wonder why Toyota put it right inside the fan housing? maybe to keep the resistors cool?

Thanks for the reply guys, good to know I can still rely on members to help out while the "SEARCH" function is no longer available.
 

·
Registered
Joined
·
1,911 Posts

·
I gots deep pockets cuz
Joined
·
952 Posts
Mine is doing the same thing and I was going to ask about it because I changed one on my wife's Impala so I figured this is what was wrong but didn't know where it was. I am going to go to autozone and see if I can get it.
 

·
I gots deep pockets cuz
Joined
·
952 Posts
Autozone didn't have it so I found an alternate parts house and it ran about $32 like someone else said and bingo it fixed everything.
 
1 - 11 of 11 Posts
Top