Supra Forums banner

1 - 9 of 9 Posts

·
Banned
Joined
·
541 Posts
Discussion Starter #1
Hey guys,


I just got a 67dbb put on my 94 6-speed. I am on stock fuel and 18psi. The problem... I have crappy tires. On the street the car starts to get traction in third. They are 275/35/19's and are not very sticky either. I have seen many suggested methods to launch but not too many about how to do it with street tires. I am going to change them out pretty soon but can't wait to get to the track.


Thanks
 

·
Not so boring anymore
Joined
·
7,085 Posts
just take off like your going from a light.. its useless to try to launch it.. haha.. just shoot for mph..
 

·
Registered
Joined
·
76 Posts
I would just wait until you get a good set of tires on there. I've been to the track on good street tires on pump and low boost and was skating the car all over the track.
 

·
The need for speed
Joined
·
1,653 Posts
I'm running a T67 with 17" TE37 rims and BFG KD tires (275 width). They hold up to 24psi in 2nd gear when warm. I think you're losing traction by having 19" rims, since you have less sidewall.
 

·
Banned
Joined
·
541 Posts
Discussion Starter #8
Thanks for the responses! It is going to be raining tomorrow when I planned on going so it will be awhile longer now.
 

·
Working OT
Joined
·
4,193 Posts
Please don't go to the track! This is how the "all supras run 13's regardless of power" myth got started. You will run a 13 or 14 and give the rest of us supra owners a bad name. Get drag radials then go. :)
Exactly don't go you're just going to be bummed out with you run a 13.9 anyway.
 
1 - 9 of 9 Posts
Top