Supra Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
629 Posts
Discussion Starter #1
For the past two days going to work if I get on it 18 psi boost then let off and my car lets out huge amouts of smoke out of the exhaust. Looks like Im crop dusting the road how embarassing! The car runs great and is boosting fine , it smokes a little in the morn and sometimes at a traffic light . But not like this Holly shit.

What test do I preform to find out the prob?
what is the prob??

help please,
chris:(

valve stem seals?
turbo seal?
 
1

·
Guest
Joined
·
0 Posts
CRM33184 said:
For the past two days going to work if I get on it 18 psi boost then let off and my car lets out huge amouts of smoke out of the exhaust. Looks like Im crop dusting the road how embarassing! The car runs great and is boosting fine , it smokes a little in the morn and sometimes at a traffic light . But not like this Holly shit.

What test do I preform to find out the prob?
what is the prob??

help please,
chris:(

valve stem seals?
turbo seal?
probably both...the morning is prolly valve stems..and traffic light....because your under vacuum for a while..it puffs out a little bit when you step on the gas in stop and go traffic.
 

·
SupraForums Member
Joined
·
434 Posts
Before I would hit 3k miles on mine i would be a quart low.

I replaced the turbos and now its happy.

So if your consuming alot of oil like i was then its the turbos.
 

·
GarageDynamics.com
Joined
·
108 Posts
What color is it? If blue it could be several reasons.
Clogged air filter element (Replace air filter element)
Obstructed air intake to the turbocharger compressor (Remove obstruction - repair parts as required per engine manual.)
Intake system air leakage (Correct leak by tightening the fasteners or replacing gaskets)
Obstruction in exhaust manifold (Tighten fasteners or replace gaskets as required.)
Blocked oil drain line (Remove obstruction or replace oil line as required)
Crankcase not vented (Clean breathing system per engine manufacturer's instructions.)
Turbo bearing housing coked, carbonated or sludged (Repair or replace the turbo and change engine oil and filter)
Internal engine problem (Repair worn valves, liners, pistons, piston rings, etc, as required.)
Black...
Clogged Air filter element Replace air filter element
Obstructed air intake to the turbo compressor (Remove obstruction-repair parts as required.)
Obstruction in the intake manifold system (Remove obstruction per engine manufacturer's instruction.)
Intake system air leakage (Correct leak by tightening fasteners or replacing gaskets.)
Obstruction in the exhaust system (Remove or repair obstruction per engine manufacturer's manual)
Exhaust system gas leak (Tighten or replace gaskets on surfaces between turbo/manifold/engine.)
Fuel injection pump or injectors out of calibration (Replace or adjust fuel system as required)
Internal engine problem (Repair defective camshaft, valves, liners, pistons, piston rings etc, as required.)
Material build up on the compressor wheel. (Clean with non-caustic cleaner. Find and correct dirty air source.)
 

·
SupraForums Member
Joined
·
434 Posts
wHEN I WAS consuming oil, I felt no lost of power and my sparkplugs looked happy. No fouling.
 
D

·
Guest
Joined
·
0 Posts
Another question about the valve stem seals.... If they are leaky, could it be the cause of bad compression #'s.

Chris
 
S

·
Guest
Joined
·
0 Posts
nope, compression numbers should not be affected by valve stem seal failure...
 
C

·
Guest
Joined
·
0 Posts
I got same problem but I only get the smoke after I am under high boost and then switch gears and punch it; after that is whenI get the puff of smoke. If I just switch gears and do not step on the gas, I see smoke about 4 seconds after I switch the gears but the puff is not nearly as dense! i HAVE A hks MEGA FLOW AND HAVE NOT CHANGED THE FILTER for 11k miles, can that be the problem?
 

·
Registered
Joined
·
2,291 Posts
CRM33184 said:
For the past two days going to work if I get on it 18 psi boost then let off and my car lets out huge amouts of smoke out of the exhaust. Looks like Im crop dusting the road how embarassing! The car runs great and is boosting fine , it smokes a little in the morn and sometimes at a traffic light . But not like this Holly shit.

What test do I preform to find out the prob?
what is the prob??

help please,
chris:(

valve stem seals?
turbo seal?
Do you have an aftermarket BOV?
 
C

·
Guest
Joined
·
0 Posts
I am not the thread starter but am experiencing similar problems and I do have an after market BOV and I do not have my stock one hooked up! I have a HKS SS!
 

·
Registered
Joined
·
629 Posts
Discussion Starter #17
yes I have the blitz kit mounted on the exhaust side. also I checked my exhaust side intercooler pipe and it does have oil in it !!!!!!!!!!! I guess that is a bad sign?? I dont know??.

Thanks for all your replys,
chris
 

·
Registered
Joined
·
2,291 Posts
I asked about the BOV because if you are running the stock MAF and have a BOV that does not route back into the intake like the stock one does, then you will run very rich between shifts. Running high boost then let off, a lot of metered air is vented, the ECU will dump the fuel for the air it thinks in in the system, but since you vented it out you end up running rich for a little while. Don't know if this is the problem or not, but it is worth checking out.
 
J

·
Guest
Joined
·
0 Posts
Hey Chris, if your lucky it could be this: Don't ask why, but one day when I was fooling around with the Greddy oil catch can, and I glued the PCV valve shut. When I reved the engine and let off the gas, there would be a huge clowd of smoke. At first I didn't know what I did to the car to make it smoke so much. Now when your doing a lot of RPM's and you let off the gas the throttle plate shuts, and there is a lot of vacuum. Thats when the PCV opens and lets in air from the crankcase. If it stays shut when you let off the gas there is so much more vacuum that oil will get pulled past whatever it can, wether its the rings, valve seals or anythin else. I got a new PCV valve and it was gone.
They do get clogged shut or open sometimes. If your lucky thats what it is. It only costs a couple dollars and I would try that first. If Toyota doesn't have one in stock, and they tell you like 11 days like they told me. You can get one at like an Autozone just to check. Good luck
 
1 - 20 of 20 Posts
Top