Supra Forums banner
1 - 13 of 13 Posts

· Just a guy who loves cars
94' Turbo, Targa, 6 spd, Ren Red.
Joined
·
792 Posts
Discussion Starter · #1 · (Edited)
Alright, so I moved back from Japan and I bought another Supra. It was previously owned by Tom Henderson of PA. I had an issue with the car, but I figured out that it was due to me coasting the car around base at low RPM. Once I figured out that the car needs to be opened up it was fine. Today I was driving back onto the base where I am stationed and all the sudden got a low fuel pressure light. The car was still running so I drove it just up the hill to my Hotel and got out. When I got out I noticed a large stream of ***(EDIT)***COOLANT pouring out from under the car. The car is low so I cant see exactly where its coming from but it looks like just behind the engine.

Once the coolant all poured out my fuel pressure went back to normal (Im assuming the fluid pouring all over something was causing the warning or a short.)

The TEMP never went above normal, the car didnt sound different. And starts normal.

My question is:
Does anyone know of a good shop around Connecticut where I can send the car to have it looked at?

I am really regretting buying this car, the car is great. I just really don't have time right now for a Supra. I kinda thought, I would still have the free time I had in Japan. But, my work load here is just TOO much. Oh, its a 95' Single turbo (T51R SPL), AEM, Titan built engine, etc.

I put Tom's name on here because he did a great job building the car, and deserves credit for it.

Any help would be Greatly appreciated.
Thanks
 

· Just a guy who loves cars
94' Turbo, Targa, 6 spd, Ren Red.
Joined
·
792 Posts
Discussion Starter · #9 · (Edited)
Ok, well I got under it today. It was coolant. But, I still cant see where it was coming from... or more importantly why! As anyone ever had a experience like this? Im going to take the laptop over there tomorrow and data log. The car has gone lean twice so I want to see what the deal there is. Im not going to tweak anything but maybe someone can look at it and tell me what the deal is.
 

· Just a guy who loves cars
94' Turbo, Targa, 6 spd, Ren Red.
Joined
·
792 Posts
Discussion Starter · #11 ·
We got it all figured out, it was just the stupid block off caps. The rubber had gotten all cracked from the heat and was leaking by. All fixed up.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top