Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
640 Posts
Discussion Starter #1
I don't know what to search for for this one...its one of those shot in the dark theories as to why my 1jz is misfiring.

So, the car automatically idles down...does the IACV control this, and then how does the fuel react to that or what exactly controls the fuel at the point where the car idles down??

Could it be that whatever is supposed to regulate the fuel AFTER the initial mode where the car is dumping fuel at startup, is not working correctly?

My car starts misfiring at idle and above randomly after about 20 seconds depending on how warm the car is...

Thanks,
Ryan
 

·
Registered
Joined
·
1,418 Posts
i believe:

the ecu runs the car rich on startup, and as the car gets closer to operating temperature the temp sensor tells the ecu, and the ecu pulls fuel while controlling the iac to drop the idle.

try checking:

coil pack connectors
coil pack (for cracks, though usually more misses as you go higher)
plugs

any codes?
 

·
Registered
Joined
·
640 Posts
Discussion Starter #3
There are no codes. The car is idling down..

I swapped the coolant temp sensor with the one from my 2jzge...no change.

what about the intake temp sensor?? What is it's purpose?

Thanks,
Ryan
 

·
Registered
Joined
·
1,418 Posts
nah, don't worry about the air temp sensor, it'll make no difference at idle if it's plugged in or not.

i'd look at your coil packs and your ecu.
 

·
Registered
Joined
·
640 Posts
Discussion Starter #5
Yea, I did pull the air sensor and it didnt do anything at all.

I've already swapped ECUs and the problem is the same.

Hopefully my new coils will arrive today so I can try them out.
 

·
Registered
Joined
·
640 Posts
Discussion Starter #6
Problem resolved, it was the coil plug wiring. 2 pins were not locked into the connectors, and 1 plug had the wires switched around.

R-
 
1 - 6 of 6 Posts
Top