Supra Forums banner

1 - 4 of 4 Posts
8

·
Guest
Joined
·
0 Posts
Discussion Starter #1
im not getting any spark in my car, ive checked all grounds, fuses, relays, tried three different coils, im gyessing it might be the ignitor. Will a ignitor from an 85 supra work. Or will i have to buy a new one. Thanks
Mike
 

·
Registered
Joined
·
74 Posts
if you got it try it, but there different systems. You don't get any spark in any wires with plugs in them,

I had to run a new ground strap for the case because i broke it off when i put in new bolts instead of screws on the valve cover.

I would check the connector, try some T pins or something to see if there is current on either side.
 

·
Registered
Joined
·
544 Posts
no an ignitor from an '85 will definitely not work... shop around for a known to be working used mk3t one i guess.
 

·
Registered
Joined
·
544 Posts
actually, if you desperately want to check if the ignitor's bad and have a spare '85 ignitor, you could wire the '85 ignitor up to the ecu and one coil and see if those two plugs fire. you'd need to know which wires are which on both the '85 igniter and your current one, and hook up power, ground, +/- to one of your coils, IGt and IGf from the ecu. i think you risk frying your '85 igniter if you accidentally hook up one of the other ecu outputs to IGt so be careful. but yeah then one of your coils ought to fire i think... if it does, i'd feel safe blaming your problem on your ignitor, if it doesn't fire, i'd explore other possibilities
 
1 - 4 of 4 Posts
Top