Supra Forums banner
61 - 80 of 85 Posts

· Registered
Joined
·
158 Posts
Im just wondering whats the diffences between a Jspec and a US spec supra? also is it cheaper to do a Jspec swap. Im thinking of pivking up an Auto N/A supra with some high miles, and buy a TT motor and swap it right away. Just wanted to see what everyone else thought.
 

· Banned
Joined
·
1,392 Posts
Sins4u33 said:
im running the n/a differential, supprisingly its holding up no problems with my drive train what so ever.

Ben Y
Pretty bad ass Ben. So whats your final drive ratio 4:2?? I know your gears are short which I prefer but that is why your not so strong on the freeway but damn you easily kept up with that z06, even with the short gear ratios!

So can you smoke that black BPU supra in that video, off of the line or is he pretty even with you ??
 

· Banned
Joined
·
2,770 Posts
Discussion Starter · #66 ·
i used a 3 inch downpipe, pretty damn big for those turbos i imagine...everyone has been asking for pics of the downpipe when i get a chance i will pop her up and snap a few pics of her under belly.... 3" to 4" exhaust is sweet

Ben Y
 

· Banned
Joined
·
1,392 Posts
toshiba75 said:
Pretty bad ass Ben. So whats your final drive ratio 4:2?? I know your gears are short which I prefer but that is why your not so strong on the freeway but damn you easily kept up with that z06, even with the short gear ratios!

So can you smoke that black BPU supra in that video, off of the line or is he pretty even with you ??

bump, soooo???
 

· Moderator
Joined
·
1,326 Posts
Congrats Ben!!! :bigthumb: Very impressive work... it's not easy to swap let alone having running right. Plus, you need practice to help me out when I get an SC. ;)

Hung
 

· Banned
Joined
·
2,770 Posts
Discussion Starter · #69 ·
toshiba75 said:
bump, soooo???
actually haven't raced that black supra off the line just yet, but we've done alot of highways rolls, my tires are getting pretty bad, but i can hold my own pretty well against most cars on the street. Poor stock twins are going though, damn thing is smoking alot....time to upgrade though!
 

· Banned
Joined
·
2,770 Posts
Discussion Starter · #70 ·
hungwin jza80 said:
Congrats Ben!!! :bigthumb: Very impressive work... it's not easy to swap let alone having running right. Plus, you need practice to help me out when I get an SC. ;)

Hung
Thanks Hung,
yeah dude, id love to do an SC next, definatley going to be a blast, the swap was alot of fun man, btw your car is looking bad ass after all youve done to it, we need to setup a meet someitme soon, maybe a BBQ or something, the weather is getting real nice!

Ben Y
 

· Banned
Joined
·
1,392 Posts
Sins4u33 said:
actually haven't raced that black supra off the line just yet, but we've done alot of highways rolls, my tires are getting pretty bad, but i can hold my own pretty well against most cars on the street. Poor stock twins are going though, damn thing is smoking alot....time to upgrade though!
Very nice =). So are you going with USDM twins or upgrading to single?
 

· Banned
Joined
·
2,770 Posts
Discussion Starter · #72 ·
toshiba75 said:
Very nice =). So are you going with USDM twins or upgrading to single?
Its in the air right now, if its cheap and worth it, then some stock USDM twins, just the labor of swapping those SOB's....but single is very tempting at the moment :p we shall see though, gotta see how the $$ comes in this season.

Ben Y
 

· feeding your habit
Joined
·
3,842 Posts
I did the swap as well... full driveline.

I'm running usdm cams, mafless, single turbo (t-70) and TT 550's and it runs awesome. I'm going aem, but just to tell you guys, the aristo auto ecu works fine with MAP. I have AEM ready to go in, but it runs so well I'm taking my time. I will put it in soon this weekend.


Ben, nice work..... What did you do with the tach. I haven't taken the time yet, but from what I understand it is just some wiring to get it to run the NA tach....

what did you do to get your tach working?

-M
 

· feeding your habit
Joined
·
3,842 Posts
gmacrae said:
Just wondering if you could answer a couple of questions i have. You're running 6spd on the aristo auto ecu right? Was there much involved in tricking the ecu to think its in park/neutral to let the car start? Did you do anything to stop the ecu throwing error codes? Does it feel like its pulling timing at certain points? Have you tried launching the car? - I've read that the auto ecu will cause the car to fall flat if you try this? though this was on a USDM auto ecu.

Im doing a manual conversion with an r154 in the next few months but haven't had any feedback about how the JDM auto ecu will respond -my car is JDM.

Thanks very much for any help you can give me.


I have not tuned my car with the aristo ECU. I've put 150 easy miles on it and aside from running a little rich at idle, it performs very well. Keep in mind I'm running low boost and going easy - breaking in the clutch and easing into it since I have no af/egt gauges. I have not launched it, but I have pushed it a little and I cannot detect anything with the timing.... it pulls very hard even running low boost.

I'm going AEM now, but the original plan was to run the aristo ECU with emanage ultimate. Now that I have had time with it, I think the emanage blue would work fine, at much less cost/work.

I'm running a 6 speed and the ecu doesn't care about the fact that it doesn't have an auto tranny hooked up. using the USDM ecu, we only had to splice one wire (the intake temp sensor on the JDM mani) and de-pin and re-pin the fusebox connector from the na harness to the TT harness (with one wire splice there). Everything fired up and works perfect so far, though I suspect I didn't turn my ac on yet (it's been 45 here!) and I think the compressor isn't coming on, but I will check that soon. I get no MIL light and have not pulled any codes for that reason.

I say run the aristo with an emanage blue or ultimate, now that I have AEM I'm going to be running it, but honestly, I could have saved $1200 and used my emanage ultimate, which I'm familiar with and have installed before.

-M
 

· Banned
Joined
·
2,770 Posts
Discussion Starter · #76 ·
98mkiv said:
I did the swap as well... full driveline.

I'm running usdm cams, mafless, single turbo (t-70) and TT 550's and it runs awesome. I'm going aem, but just to tell you guys, the aristo auto ecu works fine with MAP. I have AEM ready to go in, but it runs so well I'm taking my time. I will put it in soon this weekend.


Ben, nice work..... What did you do with the tach. I haven't taken the time yet, but from what I understand it is just some wiring to get it to run the NA tach....

what did you do to get your tach working?

-M

The tach runs off of the fuse box or off the engine wire harness? I cant remember, but i never had any problems with my tach...Let me know and ill definatley look into it or explain what i did. But im pretty sure i didnt have to do anything extensive to get the tach to work. My whole instrument cluster works perfectly.

Ben Y
 

· Banned
Joined
·
2,770 Posts
Discussion Starter · #78 ·
hmmm...it might be the engine harness to the fuse box there are 2 black wires that are suppose to be sottered together...that may be the culprit.

You did a 6spd conversion correct? Did you have the 5spd or Auto? Because i am in the midst of doing this conversion also, i finally got a tranny, i have the 6spd driveshaft, and the 6spd rear dif. I dont have the axles at the moment. But i plan to get them. I was wondering how the install went though? and what you needed exactley? I am just trying to prepare myself to reduce the downtime of my supra, before i start ripping it apart :p

Ben Y
 

· ur moms favourite
Joined
·
1,664 Posts
Great, thanks for that man.

If you do happen to 'test' the ecu a bit more, and find out anything you think i'd be interested in, please post back here - Ill keep watching :)

Gene
 

· Cheifbootknocka
Joined
·
2,117 Posts
98mkiv said:
...I'm running a 6 speed and the ecu doesn't care about the fact that it doesn't have an auto tranny hooked up....
So you dont detect any timing retard with the auto ecu ?
My plan is to run the aristo ecu with the ultimate. I have a buddy that has the blue that I could pick up cheap if that would be worth it. Im going single and fuel.
 
61 - 80 of 85 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top