Supra Forums banner

1 - 8 of 8 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
When i turn on my heat the air is blowing out cold. The blowers seem to be working fine they just won't blow any heat. I originally thought thermostat but my engine temp is fine. Once in a while when I turn it on it is hot for a few seconds then right back to cold. I just recently had #2 turbo replaced could that some how be related? Maybe something wasn't plugged in or something. If anyone has any suggestions i would ppreciate the help. Everytime I take her to the dealership they act like I'm from a different planet or something and I end up paying them to tell me they need more time to diagnose it. I don't feel like throwing more money away. Please, if anyone can help or tell me where to look for problems i would greatly appreciate it, Thanks:(
 

·
Senior
Joined
·
1,475 Posts
I had that happen on my n/a mkiii. The problem was the solenoid that allows hot coolant/water into the heater core. Just a guess though.
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
hey thanks for the reply, d you know where it is located on my car? How did you fix yours?
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Is anyone familiar with where mmy heater bypass valve is located? I know its by the heater core but before i take my dash apart i wold like to be suer where to start. Is it behind the center console or more on the passenger side?
 

·
Senior
Joined
·
1,475 Posts
On the mkiii it was located close to the firewall.I ohmed it out-it was open! Then I measured +12V @ the connector to verify that was the only fault. My guess woul be to check for any hoses going in or out of the firewall and trace to look for a valve. I'll be Dave H (who has done everything!) knows!:)
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #6
On my other car, I had the same problem, but the problem was with the thermostat being stuck open. I just replaced it and it fixed the problem.
 

·
Registered
Joined
·
313 Posts
Have you check your radiator fluid?? that might be, or could be a factor.
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Does anyone know if it is tue that my thermostat is stuck open and thats why I'm not getting any heat? I thought that if the thermostat was open then the coolant was getting through. I don't have any problems with engine temp so that leads me to believe its not the thermostat. A couple of people have told me that the thermostat is stuck open, is that a correct diagnosis?
 
1 - 8 of 8 Posts
Top