Supra Forums banner
1 - 5 of 5 Posts

· Banned
Joined
·
2,025 Posts
Discussion Starter · #1 ·
Probably a newb question, but I'll ask it anyway...

The car is a 1994 Supra w/ a SP63 and such.... 4 row I/C, blah blah blah...


@ full boost, the 4"-3" (Lowe's Special) reducer I have is popping off the inlet for the turbo... well.. maybe popping off is the wrong description... working it's way off may be a better description...

Would this be affected by the placement of the BOV? I only ask b/c previously I had the BOV mounted close to the output of the turbo (pass side) and now it's on the heavy cast pipe that comes w/ the 4-row (driver's side). Would that be causing surge?

Sorry if this is a stupid question... and yes.. I searched.
 

· Banned
Joined
·
2,025 Posts
Discussion Starter · #3 ·
Here's my thinking on the BOV location.. and yes... I've read Corky Bell's book... TWICE....

I put it as close as possible to the throttle plate (cast elbow in the 4-row piping) b/c it would react the fastest to the air in front of the plate, allowing all the air that had already made it's way through the I/C to continue, not be reversed...

I've got a t-bolt clamp on it already... not really helping much....

Damnit.....

Thanks for the suggestions B.. you gonna be @ Chargrill on Friday night?


J
 

· Banned
Joined
·
2,025 Posts
Discussion Starter · #5 ·
SteelCitySupra said:
when you use shit on your car, shit will happen. go get a silicone reducer and get back to us.

Touche' :)

I've got a 4" intake pipe on the way... with requisite re-inforced silicone couplers of course.....


OTOH.... I never had problems using the same adapter on any of my FD's....

I think it's more of an academic question about WHY....
 

· Banned
Joined
·
2,025 Posts
Discussion Starter · #7 ·
slither said:
Wolf, try the spray on adhesive then. Might be enough to get you by till your new one comes in
EDIT: yes, ill be chargrill. You gonna make it this time? I dont wanna be one of the few rice cars out there, LOL
I was there for the cruise-in on Sat...

I'll be there!
 

· Banned
Joined
·
2,025 Posts
Discussion Starter · #9 ·
Dan94TT said:
Might be a dumb anwser by me, but hell I will try to help you out anyways. I was having some trouble with blowing the IC pipes on my car and here is what I did to fix it. Take some brake clean and clean both the inside of the coupler and the inlet on the turbo that it is going on, just spray it and then wipe it down a few times with a rag, or just spray the rag and wipe with that. After that, get some aerosol hairspray and spray the shit out of the inside of the coupler and then on the turbo inlet if you wish to do so (the coupler might be enough). Then just put it all back together with the t bolt clamp and give it a few mins to dry.. after that you should be alright. I used to blow this damn IC coupler every week, since I did this I havent (*knock on wood*) blown it in about 6 months.

If this is of no help to you, Im sorry, but I just figured I would try to help ya out.
Wow man... that actually isn't a bad idea... aerosol hairspray DOES get tacky after it dries.....

thanks for the tip!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top