Supra Forums banner
1 - 2 of 2 Posts

· Stock Twins King
Joined
·
4,930 Posts
I owned this kit. It worked for me well enough to tune for open loop. I had been on the dyno at the same time as reading my gauge, and it read pretty much the same as the WB on the dyno. I used to use my digital video camera pointing at the gauge and the tach. after doing some test pulls, I would pull over, replay it while watching both guages and adjust my SAFCII. It worked for me. It is a worthles POS in closed loop. I eventually sold it and went to the FJO. The O2 that comes with the kit is OK. Most people will say this kit is a POS, but in reality, if you set it at the right #, NOT the # the install papers say, it will work.
 

· Stock Twins King
Joined
·
4,930 Posts
All I can remember, and I suggest you test it, is "11" The manual says for turbo cars to set it as "9" If I remember. Do you have the manual? If so, you will understand. It will be obvious when you get the right # vr the wrong #. It won't read right at all untill the right # is set. It has something to do with the calibration of the O2 to the guage unit.

As fas as bung size, I thing they are all the same, I can't remember if they were metric or not. I think I have an extra one laying around, let me know if you want me to check the thread pitch. Although I suggest you post on this, I am sure someone knows this answer.

Stu
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top