Supra Forums banner

1 - 4 of 4 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Not too long ago, I installed the Arizona Clutch(WOTM) in my supra and have already built up over 700 miles of daily driving to break it in easy. Tonight was the first time i went all out on my take off, and when shifting into second, a very loud jarring noise occured from letting out the clutch very fast. Is this normal? Thanks,

Zach
 

·
Registered
Joined
·
95 Posts
Last time at the track with the Arizona clutch I don't recal a jaring noise. Just the tump for shifting the trany into second. I haven't been back to the track since they told us we need cages to run again.

BPU++
11.62 @ 121.11
 

·
Banned
Joined
·
1,981 Posts
AZ Clutch.

I just got done breaking in my clutch. I put 850 miles on it before opening it up. My mileage was 95% city so my clutch was broken in properly. I'm not hearing the same noises that you are even when I race it. This clutch is badass. Maybe it's your flywheel? How many miles do you have on it?
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Re: AZ Clutch.

Chucky Doll said:
I just got done breaking in my clutch. I put 850 miles on it before opening it up. My mileage was 95% city so my clutch was broken in properly. I'm not hearing the same noises that you are even when I race it. This clutch is badass. Maybe it's your flywheel? How many miles do you have on it?
Yeah it could be the flywheel. I know usually your supposed to change your flywheel when you change your clutch, but supposedly it was still in good condition. If it doesn't go away, i think i'll put in a new one. Maintenance is so expensive!

Zach
 
1 - 4 of 4 Posts
Top