Supra Forums banner
1 - 6 of 6 Posts

· iSketch Master!
Joined
·
12,497 Posts
Discussion Starter · #1 ·
Ok here goes. I was on a cleaning fit one day and removed everything out of my bay. While it was out i took my BOV apart as there was some oil in it so I figured what the hell. Well I put it back together, no extra parts. Car is all back together and i decide to go drive around.

Now here is the problem. The thing just leaks now. At part throttle you just hear it opening and if i keep my foot at a certain point it will just shriek the ENTIRE time. Its annoying as hell. Also at full throttle run the BOV just makes a loud WHOOSH of air. Half throttle non full boost runs its the shriek again.

I cant figure out why it would be doin this, but i took it apart one other time and still does it. Imma try again today and try to figure something out. If anyone has had this happen or knows somethin i may have screwed up LMK. TIA!!!

Alex
 

· AZ RuleZ!!!!!
Joined
·
1,100 Posts
I have 2 HKS's mounted and it does the same thing, I've always wondered why it does that, sounds like a huge air leak when just keeping the gas pedal at a certain rpm... weird.. I wanna know this too...
 

· AZ RuleZ!!!!!
Joined
·
1,100 Posts
I tightened the screws, sounds somewhat better, but still that damn cruising loud whistle, sounds like a big air leak, WTF???
 

· PSN-360: SinisterSC300TT
Joined
·
464 Posts
I'm not to sure on this, but do you have a newer or older SSQV. I think older models had an adjustment nut on the back of it. Check that if anything. If not double check that the valve bodies aren't caught on anything incide the body.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top