Supra Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
538 Posts
Discussion Starter #1
Ok, so I'm pretty sure my starter is gone. When i turn the ignition all i get is a clicking. The lights go off and as soon as i turn back the key they go back on. Battery is fine. Every now and then ill get the start but its getting really really bad. So i went down to this shop and was quoted $200 for the starter and install. What do u guys think? Oh yea those are Canadian funds. I'm not gonna do it myself I'm not as mechanically inclined as I'd like to be. :dunno:


BTW, can i push start it? It got bad fast and i dont think ill get it to go anymore. :wtflol:
 

·
Banned
Joined
·
1,062 Posts
I would replace the battery wires or at least clean them very good and make sure you have a good ground before forking out that kind of money. I would say it is a pretty reasonable price since they probably have no idea how much time they will spend getting those damn bolts out. "SUCKERS" But yea I would make sure I am getting a good, constant power source to the starter.

P.S.
Yes you can push start it. Done it a whole lot of times.

Seth
 

·
Acceleration
Joined
·
3,833 Posts
Check battery connections and grounds. I didn't have a ground connected, was fine for 2 weeks, all of a sudden my car wouldn't start, and when I got it to start, it would blow the battery terminals off when I shut off the car. The battery may be fine but the connections to it may not be.
 

·
Registered
Joined
·
538 Posts
Discussion Starter #4
Well, i did redo the connections to the battery terminals. I believe the ground is fine. Do these symptoms sounds like a starter and don't worry i got this written on paper $200. Buahaha
 

·
1.5JZ Turbo Supra
Joined
·
3,378 Posts
200 bux CD doesn't sound bad at all.
 
T

·
Guest
Joined
·
0 Posts
how much is 200 canadian? :D....and that nut is a mother effing pain.. i would know did it the other week :rolleyes:
 

·
512RWHP... 503RWTQ... 7M
Joined
·
3,292 Posts
Yeah, that top nut? PITA! :lol: I think if I had to do it again, I might be willing to pay some sucker $200 to do it for me, lol...
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
check to be sure that the security system didnt go off killing the starter. might just be that by how you said you werent getting anything but a click and that it went out really fast.... but yea $200 sounds like a good deal. i did the starters on my car and my bros and man was it a PITA!
 

·
Premium Member
Joined
·
5,301 Posts
Starter contacts people! I'm surprised no on mentioned that already. That is exactly what 7 out of every 10 mk3's ive ever driven or seen do. The contacts get dirty and don't make the connections and you just get a click.

On mine, I could sit there and turn the key on and off repeatedly about 30 times in a row (the strater contacts can move very slightly during this process) and then walk away for about 5 minutes. Then come back and it woudl start right up. You can either have the contacts replaced for 10 bucks or replace the whole thing. If they only want 180 Canadian for the job, they probably don't know what they are doing. If they knew how difficult it is to get the starter out, they wouldn't charge that little. I'd be very hesitant to let someone work on my car that charged that little.
 

·
yeah thats me!
Joined
·
2,570 Posts
remove the top intake plenum and you can take tht thing out in a jiffy.
 

·
Registered
Joined
·
2,385 Posts
can you boost the car to start it (use a running car)? if so, its just the contacts, and it shouldnt cost you more than 75 bucks to get done (if not doing it yourself)
 

·
Registered
Joined
·
538 Posts
Discussion Starter #13
Ok, well just an update. I got the car to start after about 30 min of trying and i took it out of storage. I drove it around and parked it in front of my house. I go to start it again
and now it works perfect and now it starts all the time. Weird, anyone know what could of caused this? Meh, either wa the starter works now!
 

·
desufnoC
Joined
·
1,842 Posts
Trent said:
Starter contacts people! I'm surprised no on mentioned that already. That is exactly what 7 out of every 10 mk3's ive ever driven or seen do. The contacts get dirty and don't make the connections and you just get a click.

On mine, I could sit there and turn the key on and off repeatedly about 30 times in a row (the strater contacts can move very slightly during this process) and then walk away for about 5 minutes. Then come back and it woudl start right up. You can either have the contacts replaced for 10 bucks or replace the whole thing. If they only want 180 Canadian for the job, they probably don't know what they are doing. If they knew how difficult it is to get the starter out, they wouldn't charge that little. I'd be very hesitant to let someone work on my car that charged that little.
Not just on MKIII's either. I work @ a Toyota dealership, and I always give the customer an option to replace the starter contacts over replacing the whole unit. I don't think I've yet to have a situation where it did not resolve the issue.
 

·
Premium Member
Joined
·
5,301 Posts
jurkey77 said:
Ok, well just an update. I got the car to start after about 30 min of trying and i took it out of storage. I drove it around and parked it in front of my house. I go to start it again
and now it works perfect and now it starts all the time. Weird, anyone know what could of caused this? Meh, either wa the starter works now!
Did you even read what I posted? It's the starter contacts. It can go for awhile and work fine, then the wire will hit a spot that the contacts are dirty and wont' start again. That's the problem!
 
1 - 15 of 15 Posts
Top