Supra Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I bought the car, with the following:

IS300:
Engine: 2jz-gte (vvti)
Gearbox: A650E
Turbo: Single Turbonetics
Tuning: SAFC-II
ECU: IS300 N/A

The problem am facing, is a Check engine light!

It turns on randomly, not after any specific action... (Full throttle, standing by, crusing, anything!)

It will not turn off by itself, unless ofcourse I reset the ECU, by unplugging the battery...

What happens when CEL is on:
Car starts to stutter, somestimes to the extent that it ain't drivable anymore, and sometimes you bearly notice the stutter, the last time the CEL came on, it didn't stutter at all... (If it starts to stutter, it gets worse, to the extent that you can bearly launch!)

First step obviously is to check for the CEL, and whats the fault, that will be done today. but I just made this thread so that anyone who has experienced something similar, with the same symptoms can share it with us...
 

·
Check Your Face!!!
Joined
·
1,417 Posts
Well if you say your running a non-turbo ECU with 2JZGTE wiring, wouldn't that cause a load of problems? Also, that's boss to have a 2jz car with a 5 speed auto, should get a slap shift for that guy. Also could be knock sensors maybe going screwy? Just some ideas, feel free to correct my if i am way out in left field.
 

·
Registered
Joined
·
187 Posts
the IS300 ecu will work great with the setup. Figure out the codes and go from there.
Really you should get rid of the SAFC and get something that can actually modify the fuel correctly such as an EMU or FIC
 

·
Registered
Joined
·
187 Posts
EMU is the E-manage ultimate from greddy. You can also cut all fuel from the ecu and get a Haltech FX10 (older) you can also look into some of their newer platinum series like the interceptor or sprint 500 or go all out with a full standalone.

There's quite a few choices out there, but really a piggy-back type ems should do well. Unless you have the $$ to spend
 

·
Registered
Joined
·
2,141 Posts
the IS300 ecu will work great with the setup. Figure out the codes and go from there.
Really you should get rid of the SAFC and get something that can actually modify the fuel correctly such as an EMU or FIC
It'll definitely work but not even close to great. The GE MAF and GE ECU can't handle nearly as much airflow for starters.

Also, that's boss to have a 2jz car with a 5 speed auto, should get a slap shift for that guy.
the 5spd auto is weaker than the 4 speed.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #11 ·
It'll definitely work but not even close to great. The GE MAF and GE ECU can't handle nearly as much airflow for starters.


the 5spd auto is weaker than the 4 speed.
Can you explain, what do you mean by not close to great... what are the problems, and what do you suggest?


About the 5 speed being weaker... YES IT IS! especially 2nd to 3rd... I don't even try... 3rd to 4th and 4th to 5th is fine... it shifts fast no problems... but I have boost lowered to 10psi for now, just to perserve my transmission...
 

·
Registered
Joined
·
2,141 Posts
You need the 2JZ-GTE VVT-i ECU & MAF. Your 2JZ-GE VVT-i ECU can't handle boost, is calibrated for smaller fuel injectors, can't sense as much airflow. They are both 2JZ VVT-is, that's why it works, but it'll never work well. Either get the proper ECU or a standalone.
 

·
Check Your Face!!!
Joined
·
1,417 Posts
yah, i was actually kind of surprised the engine would do much more then idle with a ge ecu on it. Interesting it even works. Those parts really cant be hard, post up a WTB in the for sale section, IS300 guy.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #14 ·
yah, i was actually kind of surprised the engine would do much more then idle with a ge ecu on it. Interesting it even works. Those parts really cant be hard, post up a WTB in the for sale section, IS300 guy.
Actually if your on a budget, and its not a daily driver, I'd not touch a thing... I'd leave it exactly as it is now...!!! believe it or not...

I'm monitering my A/F ratio, and its sweet... doesn't mess up anywhere... I'm also loving the power... I leave SRT-8's in the dust... (I know thats not a big fuss) but I mean considering that my car is Automatic with the weakest transmission in the world lol! and an SAFC that the ECU is fighting... while the ECU itself is not even for the engine! let alone the modified harness... I believe its a miracle my car even works!!! haha!

believe it or not it is flawless untill the CEL comes up! I assure u flawless... but only when that light comes up... it starts to act like nothing is functional, my Wideband starts going leaner... but just a couple of 0.1 or 0.2 points leaner...

I pulled on an LP560 lambo from 120 KM till 220 where my car just stopped accelarating due to transmission restriction i believe...
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top