Supra Forums banner
1 - 9 of 9 Posts

·
Your ignorance...
Joined
·
399 Posts
Discussion Starter · #1 ·
I finally got the new motor to fire up, it ran about 1 second then died, so I restarted and did this a few times, kind of fluttering the pedal to keep it alive. I got it to run for maybe 30 sec. and when I pushed the gas, it felt like it was under load, the r's climbed real slow then it died and tripped the engine light, super monitor says code 34 - turbo pressure signal. WTF? Could an intake leak cause this? If not what am I looking at?

It won't idle on it's own, and it is choppy, but I can keep it running for a bit, but now every time, it will crap out and die eventually. Any ideas, I'm a newb to the 7mgte, but have PLENTY of experience on 5/6m's n/a.
 

·
when this baby hits 88mph
Joined
·
2,198 Posts
boost leak!
being that bad it shouldnt be too hard to find.
 

·
Your ignorance...
Joined
·
399 Posts
Discussion Starter · #3 ·
Yeah I figured it might be that. My accordion pipe is a piece of shit, I have a new one in the mail, but I didn't think that it would be boosting at idle, in neutral...
 

·
Registered
Joined
·
556 Posts
Doesn't matter...air leak = no off idle runability.
 

·
when this baby hits 88mph
Joined
·
2,198 Posts
yes what junkie said. you are losing a massive amount of air that has been metered by the afm.
 

·
Your ignorance...
Joined
·
399 Posts
Discussion Starter · #6 ·
Well that makes sense, obviously no EFI car will run right with the air metered incorrectly, but I just wondered why it said turbo pressure sensor. Not like there was pressure there; vacuum but no boost. I was under the impression that you don't boost when not under load, eg, at idle.
 

·
Premium Member
Joined
·
5,301 Posts
Code 34 usually means you have hit fuel cut.

My friends car was getting 34 all the time, but the car ran perfect and we couldn't figure out what the problem was. Reset the ECU and drove around for a few days, no code. Then drove around for another day and there was 34. He had hit fuel cut that day. Reset it again and went and ran it for a bit and then hit cut again and saw the code come back.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
a friend of mine kept getting 3psi in neutral and revving...found out the timing was too advanced.

as for code 34= boost leak...:)
 

·
yeah thats me!
Joined
·
2,570 Posts
well ill bump this thread, since my car has been idling akwardly, and after checking codes i got a code 34, and I dont think mine is fuel cut.... also I look at my AFC, and the HZ jump speradicaly, and when they jump thts when the car idles strangley...... and thoughts or input?
 
1 - 9 of 9 Posts
Top