Supra Forums banner

1 - 9 of 9 Posts

·
?!!?HABBA BABBA??!!
Joined
·
2,757 Posts
Discussion Starter #1
So im driving like this today, with nothing in my dash except my radio and speedo cluster. I noticed while i was driving a few mins ago that my O/D off light keeps flashing and my turn signals dont work either. Does this have to do with me having all the other stuff unhooked?
 

·
?!!?HABBA BABBA??!!
Joined
·
2,757 Posts
Discussion Starter #2
anyone??
 

·
Banned
Joined
·
1,281 Posts
when you unplug the hazzard blinker button your signals dont work. its the control unit for them.
 

·
Hardtop >
Joined
·
1,139 Posts
Is the top part of the dash panels removed? The one with the hazard light button on it and the odometer? If that top panel is not connected and the harness' are not connected then the turn singals and odomoter wont work.
 

·
I Can Has EBT?
Joined
·
3,331 Posts
If your odometer is unplugged, you o/d will flash. Later when you put all parts back, your airbag light will remain on.
 

·
?!!?HABBA BABBA??!!
Joined
·
2,757 Posts
Discussion Starter #7
shak said:
If your odometer is unplugged, you o/d will flash. Later when you put all parts back, your airbag light will remain on.

sweet, i knew why the turn signals didnt really work, i figure it had to do with the hazard switch, i just didnt know about the O/D flashing, now i know why its flashing. :)

Thats what i was looking for. :)
 

·
?!!?HABBA BABBA??!!
Joined
·
2,757 Posts
Discussion Starter #8
alright, so i put the dash back in. Light quit flashing and the airbag light didnt stay on either, or actually now that I think about it, ive never seen it light up to begin with, maybe that bulb is gone.
 

·
Registered
Joined
·
934 Posts
wow did not know the plug for the emergency blinkers also control the signals itself via controller. hmm weird i did go in that area today but thought i connected everything.. ill check tomorrow.
 
1 - 9 of 9 Posts
Top