Supra Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
986 Posts
Discussion Starter #1
ok im goin thru all of the learning stages of modding a turbo motor. with the 440s my plugs dont last very long, but the car was pulling fuking hard! alot harder than with the stock injectors. the first time i drove the car with the 440s and after i hooked up the spearco, i was loving it! until the motor flooded out with the gas. after dealing with the injectors and realizing my ecu was bad, i borrowed another ecu and put back in the stock injectors (everyone was tellin me to swap them back) so i did it and drove the car a few times. it was nice, but it pulled alot harder with the 440s.

the point of this story is, i wanna put back in the 440s but dont wanna deal with the plugs fouling out after a few pulls. i was using ngk 3330 and the heat range is 7. i didnt gap them either. they were already pre-gapped to about 30-something degress.

what can i do to make those plugs last??? like i said, i just want my car to pull all the time like how it did for those 30secs with the 440s.

my only mods are the ebay ypipe/downpipe, greddy sp catback modded to fit cressida, spearco intercooler (same core size as 7m drop-in).

i have a turbonetics vbc and greddy emanage blue brand new in the box. but i wanna know if theres a way i can just put the injectors and perhaps use different plugs to prevent then for not lasting long. i didnt wanna hook up the emanage yet cuz ill be selling the harness soon and didnt wanna hack it up.
 

·
Registered
Joined
·
986 Posts
Discussion Starter #2
i know you guys realized ive been asking some newb questions, but know that im actually experiencing the in & outs of modding a turbo motor on my own car, i would like a better understanding to it =)

daniel
 

·
Registered
Joined
·
297 Posts
you are trimming them up arent you? with a fuel controller or such like? you're not just using 440's bunged in and thats it?

If so, you're overfuelling, no wonder your plugs are shot.
 

·
Banned
Joined
·
341 Posts
I thought the 2j MAP would also help to even the A/F mixture. The 440's are a little bigger than the stock injectors, the 2j MAP reads a little higher than the 1j, so it evens itself out.
 

·
Engine Geek
Joined
·
359 Posts
tune it. get the emanage in there. if you start out using the 2jz map sensor tuning will probably be easier too, since it will already be close all you need to do is fine tune it.
 

·
Registered
Joined
·
1,834 Posts
I have always wanted to tune with the e-manage, but I keep hearing there are problems with it on our ecu's. Has anyone been successfull, and if so there should be a write-up. Also, is there a plug in play harness with the e-manage, or do you have to wire it in using the apexi s-afc wiring diagram?
 

·
Registered
Joined
·
427 Posts
e-manage blah. I hate that POS. Greddy = shit tech support. That's one of the reasons I used the haltech interceptor. Freakin' sweet tech support and I got it up and running quickly.

440's w/o any type of fuel controller will foul plugs. 440's flow 14% more fuel so I would remove 14% fuel at 1000 rpms with a SAFC.
 

·
LAG?? Learn to drive...
Joined
·
1,941 Posts
you should be running NGK 6097's they are the best plug for our car, and cost like $2 a plug. hell i change mine out every oil change.
 

·
Registered
Joined
·
1,834 Posts
How much would you guys say the 440's can actually flow versus the stock 370cc's? I boosted 18psi on stock twins with 440's, and had to take out a lot of fuel.
 

·
Registered
Joined
·
427 Posts
probably around 14% ~15% more fuel than the stock injectors (I thought they were 380cc). With my GT3040 at 10 psi I had to remove 10% at the top end (6000+ rpms) and my A/F according to my TE WB02 is a safe 11.5:1
 

·
Registered
Joined
·
986 Posts
Discussion Starter #14
just changed my tranny yesterday in the shop. took it for a test run, and its doin the same shit. car i cant even get a clean pull. it just starts bucking. and eventually it will cut off and give a hard time to start. i had to push my car home again. but when i got it home, it could start right back up, but it wont last long. if i start revving it, it will break up and eventually die out.

note: only mods are intake, exhaust, and spearco intercooler. the stock injectors are back in there.

i dont get it. all the problems started happening as soon as i put the intercooler on. i only got about 2minutes worth of driving. the best 30seconds was with the 440s.

what does the IACV do. cuz mine isnt gettin power, so how would this effect how my car drives.

im gonna try some different plugs. hopefully a local parts store has the ngk 6097.
 

·
Registered
Joined
·
281 Posts
My car didnt run right until I regapped my plugs to .29. But i'm currently running 15lbs of boost with my 440s pulling 30% fuel and I still run rich as a pig.
 
1 - 18 of 18 Posts
Top