Supra Forums banner

1 - 10 of 10 Posts

·
Fatty McFatty pants
Joined
·
1,279 Posts
Discussion Starter #1
Hey guys I got my cars engine replaced about 2 weeks ago and the check engine light turns on the second I start to gas and hit around 70hp(and up) and it'll just start on. Everything seems to be running fine and the last time it happened, my friend (pref0rmance) that is should just be the EGR because when he did a checkup on my engine, the light flashed 71 one time, which is for the EGR. He told me that it's because its a JDM engine and it doesnt have a EGR system, and I was just wondering could there be any other factors, because I can't, everything like I said is running smoothly and no smoke, nothing. Help me please
 

·
kaizen Motorsports
Joined
·
1,402 Posts
chewmasey said:
weird, I dont have an egr system and I dont have 71 come up, maybe the code isnt 71??

Wayne

You have a Canada car. He has a Cali car, that code is only for California. :urowned: there is a temp sensor on the EGR valve that sets that code off. Look at the TSRM to find out what the problem area is.
 

·
WhorE
Joined
·
504 Posts
onebad7m said:
You have a Canada car. He has a Cali car, that code is only for California. :urowned: there is a temp sensor on the EGR valve that sets that code off. Look at the TSRM to find out what the problem area is.

yea but my ecu and motor is from the states

Wayne
 

·
Registered
Joined
·
601 Posts
Im going to fill you in on a little something familiar to most of us in the Supra forum. If you start modding your check engine light is bound to come on sooner or later. Dont sweat something so minor. Mine has been on sense Ive owned my car cause my EGR valve is bad. We dont have emisions here so I really dont care. I check my codes once a week just to make sure everything is all right. However if it bothers you that bad theres a mod someone posted on here a while back to get it to go off. I dont remember the post but try a search and youll find it.
 

·
Be original, not a copy
Joined
·
861 Posts
Code 71 is only present on California ECUs/motors. It is for the EGR temp sensor. The sensor is located just under the EGR valve in the cast iron pipe that runs to the intake manifold. It has a 2 wire grey connector on it. The problem could be the sensor itself has gone bad (doubtful) or is disconnected, the EGR valve is leaking, or the EGR VSV (bolted on the lower intake manifold next to the master "ground" point) is bad or disconnected. If you want a "fast" solution without hunting for the problem just get a NON California 7MGTE ECU.
 

·
Registered
Joined
·
1,433 Posts
DeanMarcum said:
Code 71 is only present on California ECUs/motors. If you want a "fast" solution without hunting for the problem just get a NON California 7MGTE ECU.
This is what I was going to recommend. I have done it myself. I left off the EGR system when I installed my rebuilt JDM engine. I set code 71, it wouldnt go away. I knew the car was a Cali car when I bought it (I am 2nd owner and it even came with original window sticker) but I didnt know they were a bit different from the rest. Anyway, I got a non-cali emmisions ECU and no more code 71 because it doesnt even exist in those ECUs. Price to pay? $50 would probably be a great deal, around $100 is about normal, I paid $85 shipped from a friend here on SF.

Edit: Also try to be sure it is from the same year as your car, some years are not compatible, and if you have auto tranny it will have to be auto ecu. They will have a sticker with either A/T or M/T for auto and 5spd.
 

·
Fatty McFatty pants
Joined
·
1,279 Posts
Discussion Starter #9
wow thanks alot guys i'll look into that, but are there possibilities or other things that might be wrong? Just noticed that the power steering pressure hose have to be replaced, because its starting to leak steering fluid, but that would'nt cause the ECU to throw Check Engine codes would it?
 

·
slowly giving up...
Joined
·
1,069 Posts
i've got a JDM GTE, (no EGR, obviously:)) and i've got no codes.

and there's no reason that the check engine light should ever come on, even if you do mod the car... if the check engine light is on, you have a problem. fix it. ;)

-shaeff
 
1 - 10 of 10 Posts
Top