Supra Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
so i just washed/waxed my car, everything was great and then the next time i start up my car, anytime i accelerate (slow or fast) its pretty rough. Sounds a lot different (kinda like a subaru motor) and its not very smooth at all.
Anyone have any ideas?
thanks
 

·
Exiled Supra Owner
Joined
·
3,703 Posts
Did you wash the engine too?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
ya, but i covered distributor, entire intake, battery, and all eletronic components w/ 1 gallon trash bags
 

·
Exiled Supra Owner
Joined
·
3,703 Posts
You will need to clear out the water in the galley where the sparkplug/wires are at. It's a pool party in there.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #5 ·
hey thanks for the quick response...
pulled off the spark plug cover and looked all around....i was very careful when i hosed the inside.
any other ideas of what it could be?
 

·
Exiled Supra Owner
Joined
·
3,703 Posts
I'm assuming you took off the TB and the sparkplug cover and looked inside the galley. I'm thinking some of the water went into the sparkplug galley. Normally, the galley full of water when someone washes the engine.

As of other things I can think of: wet igniter, wet MAF, wet distriburtor/wires, wet fusebox, wet battery. I would look over anything that has a wire connected to it.
 

·
Registered
Joined
·
661 Posts
i would definitely check your plugs make sure they are all sparking.
 

·
Registered
Joined
·
178 Posts
yea these guys are right... most likely the areas where ur spark plugs go are full of water because it happened to me once except i learned the hard way, and it ended with the dealer taking a hefty amount of moola out of my pocket
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #10 ·
theres NO water in my spark plug area...pulled the first two and its dry as anything in there. im checkin the other electrical connections...but im not seein anything...ill keep lookin tho
 

·
Exiled Supra Owner
Joined
·
3,703 Posts
Esebueno said:
btw...with the plugs torqued down there, how would water get there anyway?
There is a long galley for the 6 plugs, then there is a smaller galley outlined enough for the ignition wire. If all the 6 galleys are bone dry, then I would suspect the ignition wires might have water in them (its rare to see that, but I had a friend have ignition wires gone bad from washing a engine).
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #13 ·
thanks all...been a big help. as soon as i get a little more light ill spend a good amout of time looking through all these parts making sure all the water is out of them. but its comforting to know that its just water :)
thanks again!
 
1 - 13 of 13 Posts
Top