Supra Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter #1
Ok i just finished my head gasket and everyhrting is going good then i test drove the car and as soon as it hits boost it bucks real hard and i have to clue to were to start. Any suggestions?
 

·
Banned
Joined
·
2,386 Posts
:dunno: more info would help
 

·
Registered
Joined
·
188 Posts
Discussion Starter #3
ok the car will idle a little rough, but will smooth out, then as soon as you start to drive it when its about to hit boost it starts to shutter hard and you have to shift. and i can seem to find any vaccum leaks, and its not throwing any usefull engine codes as all anymore...
 

·
Banned
Joined
·
2,386 Posts
ok..few things..might have air in the system..aka antifreeze....check the AFM..make sure everything is plugged good..sparkplugs all in tacted...and wires..check the timing..could be off
 

·
Registered
Joined
·
188 Posts
Discussion Starter #5
ok i just got it back from my dads shop they timed it in, its timed right, as fow air i didnt check that how would i do that. plugs and wires are all good. Thanks for the suggestions keep them coming i want to drive my car...
 

·
Banned
Joined
·
2,386 Posts
open the radiator cap...when the car is cold..start the car...see if you see Air Bubbles..comming out of the radiator...let is run till its at normal temp..
 

·
TheFastCoonAss
Joined
·
6,083 Posts
Sounds like a boost leak. Do a pressure test on your IC piping!

Also, did you jumper the diagnostics before timing?
 

·
Registered
Joined
·
961 Posts
Go through your IC piping and make sure everything is good and tight.. also look for any cracked couplings that may be leaking
 

·
Registered
Joined
·
188 Posts
Discussion Starter #11
ok i figured all that out thanks for the help with that it was the lower intercooler pipe...but now i have another problem, the head i put on 4 of the bolts are internally stripped. so should i tap them to 11mm or 12mm?
 

·
Registered
Joined
·
3,123 Posts
88turbocharged said:
ok i figured all that out thanks for the help with that it was the lower intercooler pipe...but now i have another problem, the head i put on 4 of the bolts are internally stripped. so should i tap them to 11mm or 12mm?
Where are the threads located?
 
K

·
Guest
Joined
·
0 Posts
What threads/bolts?

If they're exhaust manifold bolts or something like that, you can drill out the threads and put some Heli coils in. Exhaust manifold threads are 10 x 1.25.
 

·
Registered
Joined
·
1,154 Posts
mine did that when my knock sensor was broke. check to make sure it is hooked up. Also, is the check engine light on?
 
1 - 16 of 16 Posts
Top